Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 11-07-2007, 06:40 PM   #1
Badweather
Junior Member
 
Join Date: Nov 2007
Location: Ottawa, Canada
Posts: 6
Thanks: 0
Thanked 1 Times in 1 Posts
Badweather is on a distinguished road
Send a message via MSN to Badweather
Default Link2VoIP

Hey folks,

I'm having a very strange problem.

This happens when I try with X-Lite or SJPhone

Any outgoing calls I try, I get 2-way audio no problem. But when I try calling in to my DID I can hear the caller, but my audio from the softphone is not heard by the caller calling in. I've tried different codec combinations but haven't had any luck. Any echo test I have tried works fine with both softphones as well, so perhaps the problem is happening between Voxalot and Link2VoIP. Does anyone have any suggestions as to what I can try to resolve this issue.

Thanks for you time.
Badweather is offline   Reply With Quote
Unread 11-07-2007, 06:56 PM   #2
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by Badweather View Post
Hey folks,

I'm having a very strange problem.

This happens when I try with X-Lite or SJPhone

Any outgoing calls I try, I get 2-way audio no problem. But when I try calling in to my DID I can hear the caller, but my audio from the softphone is not heard by the caller calling in. I've tried different codec combinations but haven't had any luck. Any echo test I have tried works fine with both softphones as well, so perhaps the problem is happening between Voxalot and Link2VoIP. Does anyone have any suggestions as to what I can try to resolve this issue.

Thanks for you time.

How about trying to call yourself from SipBroker (Access Number then *010123456), and see if audio is working in that case.

What I'm trying to suggest is testing VoXalot in isolation of the Link2Voip DID, and see what happens with incoming calls directly to VoXalot?

Are you using it only with the SoftPhone, or with an ATA as well (does ATA work fine)

Is the ATA also registered and running in the same network the computer with the SoftPhone is running (sometimes SoftPhone and ATA are listening to the same ports and there is confusion who should handle the audio).
emoci is offline   Reply With Quote
Unread 11-07-2007, 08:54 PM   #3
Badweather
Junior Member
 
Join Date: Nov 2007
Location: Ottawa, Canada
Posts: 6
Thanks: 0
Thanked 1 Times in 1 Posts
Badweather is on a distinguished road
Send a message via MSN to Badweather
Default

Quote:
Originally Posted by emoci View Post
How about trying to call yourself from SipBroker (Access Number then *010123456), and see if audio is working in that case.

What I'm trying to suggest is testing VoXalot in isolation of the Link2Voip DID, and see what happens with incoming calls directly to VoXalot?

Are you using it only with the SoftPhone, or with an ATA as well (does ATA work fine)

Is the ATA also registered and running in the same network the computer with the SoftPhone is running (sometimes SoftPhone and ATA are listening to the same ports and there is confusion who should handle the audio).
So I called in via the sipbroker pstn in my area. What I've done is unreged my softphone so the system is going to Voicemail right away. My DID is just blank sound, although I know it answers because I get a Voicemail notification. The sipbroker in works fine and I actually hear my voicemail box. So the problem appears to be between Voxalot and Link2VoIP. What woud you suggest I try in for this? Link2Voip's support is trying to help me but unfortunately we don't have access to logs with Voxalot to see how the connections are being made in order to debug.

Last edited by Badweather; 11-07-2007 at 09:04 PM.
Badweather is offline   Reply With Quote
Unread 11-07-2007, 09:19 PM   #4
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

This thread should shed some light on your problem:

http://forum.voxalot.com/voxalot-sup...html#post10291

Unfortunately unless the embedded provider adheres to the SIP RFC there is not much we can do
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Unread 11-07-2007, 11:02 PM   #5
Badweather
Junior Member
 
Join Date: Nov 2007
Location: Ottawa, Canada
Posts: 6
Thanks: 0
Thanked 1 Times in 1 Posts
Badweather is on a distinguished road
Send a message via MSN to Badweather
Default

Quote:
Originally Posted by martin View Post
This thread should shed some light on your problem:

http://forum.voxalot.com/voxalot-sup...html#post10291

Unfortunately unless the embedded provider adheres to the SIP RFC there is not much we can do
Thanks for the reply Martin. From what I understood from the post... if I were to have Link2VoIP change my username to match my Voxalot one then it would be sent to the right user?

The strange thing is that the inbound DID reaches my voicemail, there's just no audible audio coming back. if I talk a message will be recorded with audio, so the inbound seems fine.
Badweather is offline   Reply With Quote
Unread 11-08-2007, 02:32 AM   #6
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by Badweather View Post
So I called in via the sipbroker pstn in my area. What I've done is unreged my softphone so the system is going to Voicemail right away. My DID is just blank sound, although I know it answers because I get a Voicemail notification. The sipbroker in works fine and I actually hear my voicemail box. So the problem appears to be between Voxalot and Link2VoIP. What woud you suggest I try in for this? Link2Voip's support is trying to help me but unfortunately we don't have access to logs with Voxalot to see how the connections are being made in order to debug.
1. Do exactly as you did, but leave the SoftPhone Connected and see how you hear yourself (or better yet get someone else on the phone while you talk from the SoftPhone)

2.Or go to SIPBroker - EziDial , then enter your VoXalot SIP URI 123456@voxalot.com (again replace 123456 with your VoX number). Now a call should come in from ECHO test

3.Things to do to Improve incoming issues:

-Preferably make sure you have STUN set up (stun.xten.org has been working for me)--however I don't know if the SoftPhone will have an option for this.
-If you are behind a router that has UPnP, make sure it's active
-This is optional, but it may help to open these port ranges and forward them to your ATA's IP(in your case to the IP of the computer running the SoftPhone):

5050-5064
5000-5005
16300-16500 (This is a bit hardware/software specific, it may change from one to the next, I would try doing the first two and see if they make a difference)

4. When trying to register the number initially the Optimize Audio Setting should be set to No (and the Symmetric NAT handling on the member page is set to Yes). If you do see improvement up to this point, then follow this guide to perform audio optimization:
http://forum.voxalot.com/voxalot-sup...e-quality.html

5. Finally, did you try setting up codecs as ulaw;alaw;g726;g729;ilbc;gsm


Quote:
Originally Posted by martin View Post
This thread should shed some light on your problem:

http://forum.voxalot.com/voxalot-sup...html#post10291

Unfortunately unless the embedded provider adheres to the SIP RFC there is not much we can do
I could be wrong, but if Link2Voip indeed had this problem wouldn't the SipBroker Access Numbers they provide also suffer (or is the setup different for those).

In any case wouldn't you or craig be able to set monitoring for this to see if this is indeed what's happening....
emoci is offline   Reply With Quote
Unread 11-08-2007, 03:34 PM   #7
Badweather
Junior Member
 
Join Date: Nov 2007
Location: Ottawa, Canada
Posts: 6
Thanks: 0
Thanked 1 Times in 1 Posts
Badweather is on a distinguished road
Send a message via MSN to Badweather
Default

I'm fairly certain that's it's not a network issues on my part. I'm still unable to get link2voip to get audio back from the Voxalot system (voicemail) when my DID is being directed right to it. So for now I'll try and focus on getting this working, because I don't have any other problems between my softphones and voxalot, I've done lots of echo testings, incoming and outgoing and they all work ok.
Badweather is offline   Reply With Quote
Unread 11-08-2007, 03:41 PM   #8
Badweather
Junior Member
 
Join Date: Nov 2007
Location: Ottawa, Canada
Posts: 6
Thanks: 0
Thanked 1 Times in 1 Posts
Badweather is on a distinguished road
Send a message via MSN to Badweather
Default

Well, IT WORKS!! The change I made was the suggestion to set the codec order to ulaw;alaw;g726;g729;ilbc;gsm.

When I call my DID I get audio coming of it from my softphone... success!
When I ignore the call on my softphone and Voxalot voicemail picks up I hear my greating... success!

Thanks for all the input everyone. This is such a helpful community!

BW.
Badweather is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SIP Broker Access Numbers - Status Thread martin SIP Broker Support 156 04-26-2014 10:32 PM
Busy Signal GLA313 Voxalot Support 10 07-14-2007 04:09 AM


All times are GMT. The time now is 10:34 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.