Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > SIP Broker Forums > SIP Broker Support

SIP Broker Support Support for the SIP Broker service.

 
 
Reply
Thread Tools Display Modes
Unread 02-20-2009, 09:24 PM   #1
ladude626
Junior Member
 
Join Date: Feb 2009
Posts: 15
Thanks: 0
Thanked 2 Times in 2 Posts
ladude626 is on a distinguished road
Default Symmetric NAT Handling Disabled = break SIPBroker

I'm current using SIP Broker as my VOIP for dialing 1800 numbers. When I set Symmetric NAT Handling to YES, I can make these calls but when I set it to NO I have no Incoming audio. I've successfully made calls with other providers when turned OFF Symmetric NAT Handling and audio optimization ON. Any else experiencing this problem?
ladude626 is offline   Reply With Quote
Unread 02-20-2009, 10:04 PM   #2
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

What kind of SIP user agent do you have?

Verify that your sip device/software is sending an SDP packet with your public IP address, not your LAN IP address. The problem may not occur with other providers who proxy all the voice traffic, or take measures to correct for having the LAN IP address in the SDP packet's "Connection Information" line.

Try using a STUN server.

If you prefer not to use a STUN server then do the following:
1. In your SIP client, set STUN Enable: no
2. In your router, forward the SIP ports and the RTP port range to your SIP ATA/phone.
3. In order for the ATA/phone to know it's public IP address, make sure the ATA/phone is registered with at least one SIP registrar, or enter the public IP address into the appropriate setting in the ATA (in Linksys ATAs this setting is EXT_IP).
boatman is offline   Reply With Quote
Unread 02-20-2009, 10:33 PM   #3
ladude626
Junior Member
 
Join Date: Feb 2009
Posts: 15
Thanks: 0
Thanked 2 Times in 2 Posts
ladude626 is on a distinguished road
Default

I'm using the X-Lite softphone. I've set up both Port forwarding on my router (port 5060-5080 and 10000-20000) as well as using stun.voxalot.com STUN server. What can I use to detect if my public IP is set in the SDP packet?
ladude626 is offline   Reply With Quote
Unread 02-20-2009, 11:03 PM   #4
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

There may be some logging option in X-Lite that would show SIP packets. Wireshark is packet monitoring program that works well. If you send me your Voxalot number I can call you and see what Wireshark shows.
boatman is offline   Reply With Quote
Unread 02-21-2009, 02:19 AM   #5
ladude626
Junior Member
 
Join Date: Feb 2009
Posts: 15
Thanks: 0
Thanked 2 Times in 2 Posts
ladude626 is on a distinguished road
Default

I got the call. Any information from it? And I just want to add that I only have this problem with outgoing calls. Incoming calls seem to work fine.

Last edited by ladude626; 02-21-2009 at 02:25 AM.
ladude626 is offline   Reply With Quote
Unread 02-21-2009, 03:24 AM   #6
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

I captured an SDP packet but still not sure what's going on. To which Voxalot proxy are you registering? Is your softphone using TCP transport? UDP transport is normally used for SIP and RTP packets.
boatman is offline   Reply With Quote
Unread 02-21-2009, 03:30 AM   #7
ladude626
Junior Member
 
Join Date: Feb 2009
Posts: 15
Thanks: 0
Thanked 2 Times in 2 Posts
ladude626 is on a distinguished road
Default

I belive it's using the standard UDP. I'm going to try enable DMZ on my router and see what happens because port forwarding doesn't seem to be working.


Update:

Enabling DMZ works for me while port forwarding isn't working. I'm using a WRT54G router running DD-WRT. I was forwarding ports 5060-5080, 10000-20000, and 40000-50000. That alone isn't enough. Anyway, thanks for investigating the problem for me.

The "HowTo: 6 Steps To Tune Your Voice Quality" guide should be updated with a tutorial on how to setup proper port forwarding. Anyone has any success with port forwarding?

Last edited by ladude626; 02-21-2009 at 03:53 AM.
ladude626 is offline   Reply With Quote
Unread 02-26-2009, 07:40 AM   #8
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by ladude626 View Post
I belive it's using the standard UDP. I'm going to try enable DMZ on my router and see what happens because port forwarding doesn't seem to be working.


Update:

Enabling DMZ works for me while port forwarding isn't working. I'm using a WRT54G router running DD-WRT. I was forwarding ports 5060-5080, 10000-20000, and 40000-50000. That alone isn't enough. Anyway, thanks for investigating the problem for me.

The "HowTo: 6 Steps To Tune Your Voice Quality" guide should be updated with a tutorial on how to setup proper port forwarding. Anyone has any success with port forwarding?

What ATA are you using... it helps to match the forwarded ports with the range of ports your device uses for the RTP stream...
emoci is offline   Reply With Quote
Unread 02-26-2009, 08:20 AM   #9
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Quote:
Originally Posted by ladude626 View Post
I believe it's using the standard UDP. I'm going to try enable DMZ on my router and see what happens because port forwarding doesn't seem to be working.
I asked about tcp because I saw tcp mentioned on two different lines in the SDP packet sent by your SIP unit. One was in a Record-Route line (inserted by Voxalot). The other instance was at the end of a Contact line (written by your sip unit). Both lines are shown below (I changed your Voxalot number and IP address).

Record-Route: <sip:64.34.163.35;transport=tcp;lr;r2=on;ftag=dhbd b>
Contact: <sip:123456@98.99.100.101:2473;rinstance=e14c88765 fa01a20;transport=TCP>

I am not sure if TCP transport is possible with Voxalot, but if TCP transport was being used and you were forwarding only UDP ports, that may explain why port forwarding didn't work. TCP transport is unusual for VoIP, I have not noticed any mention of it in SIP packets before this instance.

Last edited by boatman; 02-28-2009 at 02:55 AM.
boatman is offline   Reply With Quote
Unread 02-26-2009, 01:30 PM   #10
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Quote:
Originally Posted by boatman View Post
I am not sure if TCP transport is even possible with Voxalot
I can confirm we support both UDP and TCP
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The SipBroker Gateway emoci SIP Broker Support 29 02-21-2011 03:11 AM
Symmetric NAT handling issues jdstroy Voxalot Support 3 01-20-2009 05:56 AM
forwarding Sipbroker call olegp SIP Broker Support 5 10-17-2008 04:42 AM
VoXaLot Release Notes - 20070122 martin Voxalot Support 29 03-09-2007 03:59 AM
symmetric NAT handling 244751 Voxalot Support 2 02-07-2007 01:44 AM


All times are GMT. The time now is 10:50 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.