Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 03-27-2006, 01:25 PM   #1
Ron
 
Join Date: Feb 2006
Posts: 447
Thanks: 4
Thanked 8 Times in 8 Posts
Ron will become famous soon enough
Default Dial Plan Replacement Value

Why can't the replacement field value in a Dial Plan be a literal string?

I would like to be able to dial 411 and have it go off to FWD as *18007270986. I tried to be clever with ${EXTEN:3}*18007270986, which is accepted, but dialing 411 always get a fast busy.

Last edited by Ron; 03-27-2006 at 02:01 PM.
Ron is offline   Reply With Quote
Unread 03-27-2006, 04:39 PM   #2
wmp
Member
 
Join Date: Mar 2006
Posts: 65
Thanks: 11
Thanked 11 Times in 9 Posts
wmp is on a distinguished road
Lightbulb

I think the problem may be with the 411 part and not the replacement. I tried *${EXTEN:2}8007270986 as the replacement and it came out as valid under number to test. However, when dialing from the phone I get a fast busy.

Here is an option I verified as working. Set 411 as the Speed Dial number and in the SIP URI enter sip:*18007270986@fwd.pulver.com. Then just dial **411. Not as elegant as simply dialing 411, but it works.
wmp is offline   Reply With Quote
Unread 03-28-2006, 01:29 AM   #3
Ron
 
Join Date: Feb 2006
Posts: 447
Thanks: 4
Thanked 8 Times in 8 Posts
Ron will become famous soon enough
Default

Speed dial would be an option, but I don't see any reason NOT to allow literal strings as the replacement value, expecially since you're allowed to apply prefixes and suffixes to ${EXTEN}. It appears the problem is simply a validation check issue on the web page form.
Ron is offline   Reply With Quote
Unread 03-28-2006, 03:01 AM   #4
wmp
Member
 
Join Date: Mar 2006
Posts: 65
Thanks: 11
Thanked 11 Times in 9 Posts
wmp is on a distinguished road
Lightbulb

Here's another option that works. Using the Dial Plan on my SPA2000 I added <411:*18007270986><:@fwd.pulver.com> as the first entry. Of course this skips Voxalot, but using this method allows you to just dial 411.
wmp is offline   Reply With Quote
Unread 03-28-2006, 03:50 AM   #5
Ron
 
Join Date: Feb 2006
Posts: 447
Thanks: 4
Thanked 8 Times in 8 Posts
Ron will become famous soon enough
Default

Quote:
Originally Posted by wmp
Here's another option that works. Using the Dial Plan on my SPA2000 I added <411:*18007270986><:@fwd.pulver.com> as the first entry. Of course this skips Voxalot, but using this method allows you to just dial 411.
Yes, I'm aware of all these work-arounds, but they don't get the bugs worked out of VoXaLot .
Ron is offline   Reply With Quote
Unread 03-28-2006, 08:05 AM   #6
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Yep it is a validation bug that we will fix. Thanks for letting us know.
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Unread 03-29-2006, 11:55 AM   #7
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Guys this should now be fixed. Please advise.
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Unread 03-29-2006, 12:32 PM   #8
Ron
 
Join Date: Feb 2006
Posts: 447
Thanks: 4
Thanked 8 Times in 8 Posts
Ron will become famous soon enough
Default

Martin,

The validation problem is gone, but it doesn't produce the correct results.

My dial plan is:

_4111 *18003733411 Free World Dialup

and the test is:

A call to:4111 will get forwarded to sip:4111@fwd.pulver.com.

It appears it's totally ignoring the subsitution operation.

Ron
Ron is offline   Reply With Quote
Unread 03-29-2006, 09:53 PM   #9
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Hmm it appears the corresponding SIP proxy change was not deployed. Can you please retry?
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Unread 03-29-2006, 11:17 PM   #10
Ron
 
Join Date: Feb 2006
Posts: 447
Thanks: 4
Thanked 8 Times in 8 Posts
Ron will become famous soon enough
Default

Both the web page test and actual dialing appear to be working properly now.

Thank you.

Ron
Ron is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Voxalot and Sipura/ATA Tutorial: A Comprehensive Walkthrough ctylor Voxalot General 5 04-28-2010 12:52 AM
Dial plan problems with FaktorTel and VoXaLoT Hally Voxalot Support 1 01-06-2007 09:21 AM
Norway toll free number dial plan ? shezad Voxalot Support 1 11-11-2006 12:09 AM
dial plan help please muzzza Voxalot Support 0 09-01-2006 11:38 AM
Dial Plan for Italy wanted!!! moonshiner Voxalot Support 32 08-20-2006 10:26 PM


All times are GMT. The time now is 09:25 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.