Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 01-06-2008, 11:21 AM   #1
pradeepjella
Junior Member
 
Join Date: Jan 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
pradeepjella is on a distinguished road
Unhappy Call drops after 21 seconds

Hi all,

I am a Premium subscriber and I am using Grandstream HT488 device with an FXS and another FXO account. Both accounts are configured to register with two different Voxalot accounts. FXS account uses 2060 port, whereas FXO account uses 3060 port.

I have a VoipDiscount account configured on the FXS Voxalot account with Symmetric NAT Handling set as 'No' and Optimize Audio Path set as 'Yes'. The *600 echo test is successful. The same configuration worked properly before Voxalot launched VoxPremium. Then I shifted to some other VSP. Now I purchased VoxPremium and setup the same exact configuration.

The problem is that calls going through VoipDiscount go silent after exactly 21 seconds and they are disconnected (as I see from my VoipDiscount call log, they get disconnected after exactly 21 seconds). I have performed the following steps:

1. It works properly if I connect to the Voxalot account from EyeBeam (X-Lite).
2. It also works properly if I directly configure the VoipDiscount account on my HT488 ATA.
3. I also tried setting the Symmetric NAT Handling to 'Yes' and Optimize Audio Path to 'No'.
4. *600 echo test lasts for more than 21 seconds and has no problems.
5. *1800 and other toll free numbers that go through Voxalot itself without using any VSP's also don't have any problems.
6. I tried setting the "Register" option for the VoipDiscount account to 'Yes' and 'No' both. But still the problem persists.
7. I changed the preferred cluster server to eu.voxalot.com and similarly changed the connection server on my ATA. The problem still persists.
8. I don't have any other VSP's configured in Voxalot in order to test calls going through them.

Please let me know what else could be the problem. If it seems like a re-INVITE issue, then does VoipDiscount send a re-INVITE after 20 seconds? Also, it still seems like a mystery to me as the same exact configuration worked with Voxalot before the launch of VoxPremium.

I can provide screenshots of my ATA configuration as well as Voxalot configuration settings if required.

Regards,
Pradeep
pradeepjella is offline   Reply With Quote
Unread 01-06-2008, 06:07 PM   #2
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

I did set up an HT-488 a few months ago, and it has been working reliably.
I have a Voxalot account on the FXS port using Poivy as an outgoing PSTN provider.
The FXO SIP account is using another VSP.
I do not have access to the settings as this ATA is currently 5000 miles away.

Some suggestions :
1) Update to the latest firmware (The FXO port did not work properly with earlier firmware)
2) Use the default SIP ports 5060 and 5062
3) Use different RTP ports (Eg 5004, 5006) for the FXS and FXO ports
4) Use a STUN server (Eg. stun.voxalot.com.au:3478)
5) If you are behind a router, it might help to forward the SIP ports (5060-5063) and the RTP ports (5004-5007) in particular.

You might want to try setting up the FXS port by itself first (with the FXO port disabled) until you trace the cause of the 21 second call-drop problem.
kurun is offline   Reply With Quote
Unread 01-07-2008, 04:09 AM   #3
telenerd
Junior Member
 
Join Date: Jul 2007
Posts: 23
Thanks: 2
Thanked 1 Times in 1 Posts
telenerd is on a distinguished road
Default

There is a known bug in asterisk that causes similar problems. However a message trace is necessary to confirm if this is the source of your problem. The bug is unusual in that some phones will work and others will not under the same conditions but the bug is not in the phone but rather in asterisk. I will not go into an explanation here as it is rather long and it is well documented elsewhere.

Refer to the following --
In sipbroker forum see Another misrouted ACK
In bugs.digium.com see 0011230, 0011326 and 0011545
telenerd is offline   Reply With Quote
Unread 01-07-2008, 04:45 PM   #4
victor
Junior Member
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
victor is on a distinguished road
Default

I'm also a Premium subscriber and experiencing the same issues, but only for incoming calls from every SIP I have registered.

When someone calls, my TC-300 rings and the call goes on perfectly until it reaches 21 seconds, then the caller gets disconnected and my phone still shows the call as active until I have to hang up manually.
victor is offline   Reply With Quote
Unread 01-08-2008, 01:36 AM   #5
pradeepjella
Junior Member
 
Join Date: Jan 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
pradeepjella is on a distinguished road
Default Problem still persists

I performed all the steps as Kurun said. Upgraded the firmware, used STUN server, setup port forwarding in my ISP's router and also disabled the FXO port & tested only with the FXS port configuration. Still the same problem persists. Though the only thing is that my ISP blocks regular SIP & RTP ports. So, I am not able to use any ports in the 5000 range. I have set RTP ports as 2004 (FXS) & 3008 (FXO).

The HT-488 works well if I set it up directly with any other VSP instead of Voxalot. But the surprising thing is that I used the same exact configuration with same HT-488 settings, same VSP's configured in Voxalot, everything same before Voxalot launched VoxPremium. Everything worked well then.

I am not sure what that problem could be now. I am willing to give as much as possible to get this problem resolved. Any thoughts anyone? Martin?
pradeepjella is offline   Reply With Quote
Unread 01-11-2008, 10:04 AM   #6
haifischjunge
Member
 
Join Date: Apr 2007
Location: Vienna, Austria
Posts: 56
Thanks: 5
Thanked 4 Times in 4 Posts
haifischjunge is on a distinguished road
Default

ive got the same problem with inbound, the connection lasts 19 sec and then breaks up. echotest and calling out works as usual...
haifischjunge is offline   Reply With Quote
Unread 01-11-2008, 10:28 AM   #7
pradeepjella
Junior Member
 
Join Date: Jan 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
pradeepjella is on a distinguished road
Default

Hi victor & haifischjunge,

Can you please mention which hardware ATA adapter you are using?

Also mention the VSPs your are registering against where you are facing these problems.

I am facing problems with Betamax VSPs registered within Voxalot for outgoing calls.

Regards,
Pradeep
pradeepjella is offline   Reply With Quote
Unread 01-11-2008, 11:04 AM   #8
victor
Junior Member
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
victor is on a distinguished road
Default

Quote:
Originally Posted by pradeepjella View Post
Hi victor & haifischjunge,

Can you please mention which hardware ATA adapter you are using?

Also mention the VSPs your are registering against where you are facing these problems.

I am facing problems with Betamax VSPs registered within Voxalot for outgoing calls.

Regards,
Pradeep
I'm using a TC-300 dual phone and I have tried incoming calls from two different VSPs; ipfon.pl and carpo.net, both facing the same issue.
victor is offline   Reply With Quote
Unread 07-02-2008, 11:36 PM   #9
TheFug
Member
 
Join Date: May 2008
Posts: 80
Thanks: 3
Thanked 7 Times in 6 Posts
TheFug is on a distinguished road
Default

Quote:
Originally Posted by victor View Post
I'm using a TC-300 dual phone and I have tried incoming calls from two different VSPs; ipfon.pl and carpo.net, both facing the same issue.
Guess i'm joining this one too all outbound calls will only last 21 seconds,
discovered it's not ATA, softphone, or IP phone, my guess routing is somewhere the blame, and this also limits the use of Voxalot, because you can't voip from the laptop this way, (WiFi)
TheFug is offline   Reply With Quote
Unread 07-05-2008, 11:04 AM   #10
TheFug
Member
 
Join Date: May 2008
Posts: 80
Thanks: 3
Thanked 7 Times in 6 Posts
TheFug is on a distinguished road
Default

I now know it has nothing to do with the ATA, but somewhere in the routing, or protocol, because an older modem/router don't have the problem, but also less internet security..
TheFug is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
SIP call to voxalot number Kenthurst35 Voxalot Support 0 01-03-2008 12:17 PM
Call drops every 3 to 5 minutes bokaroseani Voxalot Support 19 10-31-2007 09:23 AM
Voice part of call dropping at 30 seconds Ambient Voxalot Support 10 10-19-2007 10:13 PM
Ack (Acknowledgement Timeout) on Soft phone - call lasts 30 seconds kurun Voxalot Support 1 10-01-2006 05:52 AM


All times are GMT. The time now is 09:21 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.