Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 09-19-2007, 11:33 PM   #1
nacho
Junior Member
 
Join Date: Aug 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
nacho is on a distinguished road
Unhappy Problem - I can´t hear and they can´t hear me

I have the following problems.
1. When I make a phone call to a PSTN line people can´t hear me and I can´t hear them.
2.If someone phones me on my voxalot number they can hear me and I can hear them.
3. I can dial a pstn line and it ring the other party, but we cannot hear each other.
4. If I dial another voxalot user nothing happens.

Does this have something to do with the NAT SUPPORT PARAMETERS?
I´ve seen on some tutorials to specify most of this setting in NO, but I realized that when doing this I could not hear nor other voxalot users could hear me.
But if I specify this parameters in YES, then I could talk to other voxalot users.

Which setting should I setup on NAT SUPPORT PARAMETERS? (I dont know what are these parameters for, but I guess that the problem is here)

Could someone help please?

Im using a sipura spa-2002 connected to a router.
My current NAT SUPPORT PARAMETERS are:
Handle VIA received YES
Insert VIA received YES
Subsitut VIA Addr YES
Stun Server: stun.xten.com
EXT RTP Port Min: blank
Handle VIA rport YES
Insert VIA rport YES
Send Resp To Src Port YES
Stun Test Enable NO
Ext IP: blank
NAT Keep alive Intvl 28

Last edited by nacho; 09-19-2007 at 11:50 PM.
nacho is offline   Reply With Quote
Unread 09-20-2007, 12:09 AM   #2
ctylor
 
ctylor's Avatar
 
Join Date: Apr 2006
Location: Vancouver, BC
Posts: 296
Thanks: 94
Thanked 53 Times in 27 Posts
ctylor will become famous soon enough
Default

Did you try my suggestions found here:
http://forum.voxalot.com/voxalot-gen....html#post5813

Edit: you have now tried some of my suggestions. Thanks.

Be careful, you can't change all those STUN settings to yes, as far as I know. You have to do one or the other, as I tried to show in my Walkthrough guide by showing one setup then another, swapping what was Yes and what was No.

Last edited by ctylor; 09-20-2007 at 01:58 AM. Reason: Update
ctylor is offline   Reply With Quote
Unread 09-20-2007, 12:59 AM   #3
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
1. When I make a phone call to a PSTN line people can´t hear me and I can´t hear them.

3. I can dial a pstn line and it ring the other party, but we cannot hear each other.
Check to see that the codecs as you've set them up in VoXalot are compatible with the Codecs your outgoing provider supports (who are you using for outgoing calls

Quote:
2.If someone phones me on my voxalot number they can hear me and I can hear them.
So everything here works fine there, correct?

Quote:
4. If I dial another voxalot user nothing happens.
This is likely a problem with the dial plan in your ATA, try adding something like this to the string xxxxxx , or better yet post you dial plan so we can give some suggestions

Quote:
Does this have something to do with the NAT SUPPORT PARAMETERS?
I´ve seen on some tutorials to specify most of this setting in NO, but I realized that when doing this I could not hear nor other voxalot users could hear me.
But if I specify this parameters in YES, then I could talk to other voxalot users.

Which setting should I setup on NAT SUPPORT PARAMETERS? (I dont know what are these parameters for, but I guess that the problem is here)

Could someone help please?

Im using a sipura spa-2002 connected to a router.
My current NAT SUPPORT PARAMETERS are:
Handle VIA received YES
Insert VIA received YES
Subsitut VIA Addr YES
Stun Server: stun.xten.com
EXT RTP Port Min: blank
Handle VIA rport YES
Insert VIA rport YES
Send Resp To Src Port YES
Stun Test Enable NO
Ext IP: blank
NAT Keep alive Intvl 28
For this stuff ctylor's guide is pretty good at explaining everything
emoci is offline   Reply With Quote
Unread 09-20-2007, 05:25 PM   #4
nacho
Junior Member
 
Join Date: Aug 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
nacho is on a distinguished road
Unhappy the problem is with ADSL, I cant hear but they can hear me

The problem seems to be with the type of connection

Test 1: sipura connected to a cablemodem connection.
Result: EVERYTHING OK!!!!

Test 2: same sipura connected to an ADSL connection.
Result: I hear dial tone, but then after dialing I dont hear anything, not even the other party ringing, but the other party hears me. But on cablemodem works.

Which is the setting I must change in order to work with ADSL?

I use as provider BETAMAX (INTERNETCALLS)

Thanks in advance
nacho is offline   Reply With Quote
Unread 09-20-2007, 05:56 PM   #5
nacho
Junior Member
 
Join Date: Aug 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
nacho is on a distinguished road
Unhappy I can´t hear, but they can hear me

Quote:
Originally Posted by nacho View Post
The problem seems to be with the type of connection

Test 1: sipura connected to a cablemodem connection.
Result: EVERYTHING OK!!!!

Test 2: same sipura connected to an ADSL connection.
Result: I hear dial tone, but then after dialing I dont hear anything, not even the other party ringing, but the other party hears me. But on cablemodem works.

Which is the setting I must change in order to work with ADSL?

I use as provider BETAMAX (INTERNETCALLS)

Thanks in advance

Just now if realized that...
I realized on the DLINK DI604 LOG, that it is blocking some UDP ports.
Can you tell me which UDP ports shall I enable?
Or shall I configure something else?
Can the audio problem be due to this UDP blocking?

I now specified a range of UDP ports to allow, from 0 to 30000.

Now on the DLINK log I see the following when trying to make a call
Thursday September 20, 2007 10:02:13 Unallowed access from 192.168.0.179:16460 to 64.34.173.199:12244 protocol=17 rule=9

What should I do to allow the access?

Last edited by nacho; 09-20-2007 at 06:05 PM.
nacho is offline   Reply With Quote
Unread 09-20-2007, 06:48 PM   #6
nacho
Junior Member
 
Join Date: Aug 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
nacho is on a distinguished road
Unhappy I cant hear, problem seems to be on router setting

The router log reports
Thursday September 20, 2007 10:45:25 Unrecognized attempt blocked from 64.34.173.199:17580 to 190.172.23.78 UDP:16454

Is this the reason why I can´t hear?

Please help!!!
What should I do?
nacho is offline   Reply With Quote
Unread 09-20-2007, 07:55 PM   #7
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

It could be....

Is there anything about UPnP in your router, make sure UPnP is active....

What's your setup like, you use a different modem for DSL/ADSL behind which you put a router?

Any chance there is sopme sort of firewall on the modem itself....

I would suggest not blocking any ports, and opening the following and pointing them to your ATA's IP (open both UDP nad TCP):

5050-5064
5000-5005
16300-16500

Also enable stun in your ATA (use stun.xten.org)

Quote:
Thursday September 20, 2007 10:02:13 Unallowed access from 192.168.0.179:16460 to 64.34.173.199:12244 protocol=17 rule=9
This looks like you tried to make a call out, and a rule is blocking the traffic (16460 and 12244 are ranges usually handling RTP packets, so they handle the audio)

64.34.173.199 VoXalot's IP
192.168.0.179 This looks like the internal IP of your ATA

Definitely seems like like the router is getting on the way (btw, if you have DMZ enabled, disable it and activate UPnP instead if it's there, or open those ports)

Last edited by emoci; 09-20-2007 at 08:03 PM.
emoci is offline   Reply With Quote
Unread 09-21-2007, 04:39 AM   #8
nacho
Junior Member
 
Join Date: Aug 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
nacho is on a distinguished road
Smile Problem sorted out

Thanks a lot!

The problem was that the router was blocking.
I configured the sipura with static ip and specified that ip on the DMZ of the router.

nacho is offline   Reply With Quote
Unread 09-21-2007, 05:25 AM   #9
nacho
Junior Member
 
Join Date: Aug 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
nacho is on a distinguished road
Default

Thanks my friend!!!!!!!!!
nacho is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:14 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.