View Single Post
Unread 04-12-2007, 02:06 AM   #1
Join Date: Mar 2007
Posts: 83
Thanks: 5
Thanked 13 Times in 10 Posts
wilsonhlacerda is on a distinguished road
Default VoXaLot not working with PBXes (VoXaLot as an extension of PBXes)

Hi all.

As I can not have VoXaLot registered to one of my providers
(see this here: )
I created a free PBXes account in order to have it as a bridge between my provider and VoXaLot (just create an extension in PBXes, register VoXaLot to it and create a trunk in PBXes to you provider with all inbound calls routing to the extension). This can be an useful temporary solution for all of you that have the same problem with VoXaLot.
Everything worked fine for a day or two. But now I'm having some problems with VoXaLot that maybe you can help me: there's no audio.

Well, just for a while forget the "bridge". The problem is more generic: VoXaLot is not properly handling codecs when receiving a call from PBXes. I created 2 extensions in PBXes: 200 and 300. I registered VoXaLot to 300 and I have an ATA registered to VoXaLot. I registered X-PRO softphone to extension 200. If I call from my ATA to extension 200 (voxalot -> pbxes) evething work fine. BUT if I call from my X-PRO to extension 300 (pbxes -> voxalot) my ATA rings but there's no audio. I can see in X-PRO that there's no codec set for the voip connection (none of them gets that square around it in the X-PRO display).
This happen no matter if I put only G729 or only iLBC or all codecs in VoXaLot. And also no matter if I select yes/no in the "audio bypass" options in PBXes or "Enable symmetric NAT handling" option in VoXaLot.

What's strange is that everything worked fine for a day or two and now it definitely do not work. And all of my tests suggests it is a problem within VoXaLot now.

Do you have VoXaLot working fine as an extension of PBXes? Can someone help me?

Last edited by wilsonhlacerda; 04-12-2007 at 07:40 AM.
wilsonhlacerda is offline   Reply With Quote