View Single Post
Unread 08-16-2007, 01:06 AM   #9
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all

It seems:

You dial 04xx xxx xxx, ATA sends to VoXalot 04xx xxx xxx

You dial 1300 xxx xxx, ATA sends to VoXalot 61 1300 xxx xxx
You dial 1800 xxx xxx, ATA sends to VoXalot 61 1800 xxx xxx

You dial 131 xxx, ATA sends to VoXalot 61 131 xxx
You dial 139 xxx, ATA sends to VoXlaot 61 139 xxx

You dial 02xx xxx xxx, ATA sends to VoXalot 02xx xxx xxx
You dial 09xx xxx xxx, ATA sends to VoXalot 09xx xxx xxx

You dial 1xxx xxxx, ATA sends to VoXalot 612 1xxx xxxx
You dial 9xxx xxxx, ATA sends to VoXalot 612 9xxx xxxx

You dial 001 xxx xxx xxxx, ATA sends to VoXalot 001 xxx xxx xxxx

If you dial 61 414 XXX XXX it should send VoXalot 61 414 XXX XXX
Unless it is getting confused and sending 612 6141 4xxx

Ok, now take all those patterns that are supposed to be sent to VoXalot and test them against your VoXalot Dial Plan (you are gonna wanna fill the x-es)

Another helpful thing, my PAP2 for example shows last dialed call, and gives the number string exactly as it sends it out after all the manipulations by the dial plan. Any chance your ATA gives you that info, cause it would help to analyze what VoXalot is actually receiving from your ATA and how it is processing that.

I would also suggest trying this for test purposes:
(*xx.|**x.|<59,:>xx.<:@gw0>|<51,:00>xx.<:@gw1>|<52 ,:>xx.<:@gw2>|<53,:>xx.<:@gw3>|<54,:>xx.<:@gw4>|00 0|00x.|xxx.)

Then dial the number in the full format PennyTel expects, and see if it works.

BTW, the * at the end of the plan, after the bracket, is it a typo or is there some reason to it.

To try and answer your question, registration should be the issue in this case...

If all fails, get another VoXalot acocunt and see if it is account specific...

That remove and add procedure I suggested, where you completely erase, let rest and readd each provider may help too..

Originally Posted by vxvl View Post
Thanks for your time and effort.

My ATA dial plan is as follows:

(*xx.|**x.|<59,:>xx.<:@gw0>|<51,:00>xx.<:@gw1>|<52 ,:>xx.<:@gw2>|<53,:>xx.<:@gw3>|<54,:>xx.<:@gw4>|00 0|04xxxxxxxx|<:61>1[38]00xxxxxx|<:61>13[1-9]xxx|0[2-9]xxxxxxxx|00x.|<:612>[1-9]xxxxxxx|xxx.)*

Pennytel is my most used provider and does not require the 00, just country code onwards and for mobiles it will accept 04XX XXX XXX. I have tried both.

I had changed the registration of my Pennytel account to be with Mysipswitch for receiving calls on my DID (works fine) and I used Voxalot registered with my ATA but as I said I can make calls - using 5X prefixes with the gateway function of my ATA and get no problems. This means that the VSPs I use don't require any registration doesn't it? Voxalot should be able to do the same thing as my ATA gateway function to make the call successfully so it would appear that it is a Voxalot issue. The example test for Pennytel gave which is right for Pennytel. For Voipdiscount you need 00 and I have accommodated this.

The speed dial is accommodated for in the plan with **x and worked previously. Also Voxalot's speed dial has the numbers to dial as required by each VSP e.g., Voipdiscount needs the 00 and the rest eg, 61 2 XXXX XXXX. These also worked previously but now I get the busy tone for each and every one of my different speed dials using different VSPs.

I know this is peculiar because it was working fine before and I think I know what I'm doing but I must be missing something or there is a problem peculiar to my Voxalot account.
emoci is offline   Reply With Quote