Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (https://forum.sipbroker.com/index.php)
-   Voxalot Tips, Tricks & HowTo's (https://forum.sipbroker.com/forumdisplay.php?f=17)
-   -   Nokia Support (https://forum.sipbroker.com/showthread.php?t=427)

fozzie 09-10-2006 12:40 PM

I think you'll find that that Nokia don't formally support NAT traversal (yet) and that the SIP stack is fairly rudimentary. Softphones are better at detecting the presence of NAT and self configure accordingly.

You might want to take a look at your home router and see if there are any settings related to SIP ALG (application layer gateway). Many home routers have faulty SIP ALG implementations which mangle the SIP headers, preventing devices from registering. Check you have the latest firmware on the router (manufacturers are releasing fixes in this area) but most importantly, if there are any settings relating to SIP ALG, I would turn them off.

What router do you have?

martin 09-10-2006 01:03 PM

VoXaLot has NAT handling on the server side. The E-Series phones should work behind most firewalls and the NAT traversal is provided by the VoXaLot and RTP proxies.

fozzie 09-10-2006 01:20 PM

That may be the case, but if the router has mangled the SIP headers, there's nothing you can do about it from the proxy side; the proxy will be blissfully unaware ;)

jyavenard 09-11-2006 06:32 AM

Using default Linksys WRT54

I use the default firewall provided by the Linksys WRT54.

I connect to voxalot just fine with a client on my PC like x-lite on the same wireless network as the one I'm trying to use with my Nokia E70 phone.

I have set the phone as described here. If I use 3G , then the phone will register fine. But not on my home wireless connection
Profile Name: Voxalot
Service profile: IETF
Default Access Point: Home (802.11g access point)
public user name: sip:xxxxxx@voxalot.com
Use compression: No
Registration: Always on
Use security: No

Proxy Server:
Proxy server address: sip:
Realm: voxalot.com.au / voxalot.com (tried both)
username: xxxxxx
password: my_password
Allow loose routing: Yes
Transport type: UDP
Port: 5060

Registrar Server:
registrar server address : sip:voxalot.com.au
Real: voxalot.com.au / voxalot.com
username: xxxxxx
password: my_password
transport type: UDP
port: 5060

harrip 09-12-2006 06:36 AM

I'm trying to make my first proper PSTN call via the Nokia E61 with the Voxalot set-up.

I've configured my dial plan so all calls get routed via mynetfone. So, for example, a Sydney number of 61212341234 appears to get routed via

Could any one advise what should I be entering so rather than going via sip, a PSTN call is made? I'm trying to find out from myNetPhone but so far without success.


martin 09-12-2006 08:19 AM

What does your dial plan entry look like (are you able to cut and paste)?

Also what does the dial plan "Test" button report when you enter that number?

Does a call to 600 work ok?

harrip 09-12-2006 08:25 AM

Hi Martin

My dial plan looks like this:

Priority Pattern Replacement Provider Active
1 _X. ${EXTEN} My Net Phone Yes

(hopefully this routes anything and everthing via mynetphone).

When I enter the test number, I get the following:

A call to:61212341234 will get forwarded to sip:61212341234@

A call to:600 will get forwarded to sip:600@ - but I hear a busy tone.

Presently I'm getting 'number busy' for any number that I enter. Except for ENUM Number: 18005551212 which works. What I dont understand is why this is routed as follows:

A call to:18005551212 will get forwarded to sip:18005551212@tf.voipmich.com

Thanks for your help.


Golab 09-13-2006 08:37 PM

hello, im trying to get my acount on www.woize.com to work, Can call out but not get eney calls, can sombodey pleas try to register acount on www.woize.com and try if u can get it to work, im using E61

// Sorry About My Spelling Im Dyslectic \\

arnie 09-16-2006 04:40 PM

I finally got my E60 to register with the voxalot service. If I dial the test numbers it is okay, but I can't get my inbound calls to work. I'm behind a NAT firewall.... so that might be the problem. But it is said that voxalot has resolved this issue... so I was hoping that it would work.

Could anyone tell me if this is normal (not being able to receive calls) or can it be changed by any setting?

fozzie 09-16-2006 07:43 PM

What do you mean by when you say that inbound calls don't work? Do you mean the phone doesn't ring, or that it rings but when you answer, there's no audio?

I wouldn't say normal, but is it quite common. Unfortunately, I don't think there's a lot you can do on the handset to resolve this, as it doesn't support STUN.

Have you tried port forwarding on the router?

All times are GMT. The time now is 12:50 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.