Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (https://forum.sipbroker.com/index.php)
-   SIP Broker Support (https://forum.sipbroker.com/forumdisplay.php?f=9)
-   -   SIPbroker w. Asterisk DTMF not working (https://forum.sipbroker.com/showthread.php?t=3399)

ineagu 09-09-2008 03:01 PM

SIPbroker w. Asterisk DTMF not working
I m calling into my asterisk server (into a conference for example) thru SIP broker PSTN gateway and the call reaches fine but the DTMF are not sent...
any ideas ?
thank you
ilie neagu

vk4akp 11-23-2008 11:59 AM

I have had the same problem on and off for weeks. It's the gateways. There not working properly. They are also dropping the calls out after the first few seconds.

vk4akp 12-11-2008 02:44 PM

Any fix for no DTMF via SipBroker PSTN Gateway?
Hi, Can anyone help with this? Is there a fix to get the DTMF working from a SipBroker PSTN Gateway to an Asterisk box?

It used to work fine. Whats changed in the last month or so?

I've tried all sorts of changes to sip.conf but nothing works. :(

Help please Sipbroker. We need DTMF for the users to select options in our menu's. :(

vk4akp 12-11-2008 03:36 PM

G.729 works but is random
I've done some more experimenting tonight.

I've noticed that in about 1 in every 4-5 calls Sipbroker negotiates a G.729 call with my Asterisk box. At this point the DTMF signaling works fine.

Every other call is uLaw and DTMF fails with this every time.

I have tried every possible setting for DTMF.

dtmfmode = rfc2833 ; The default setting
dtmfmode = inband
dtmfmode = info
dtmfmode = auto
relaxdtmf = yes

None of these made any difference.

I can only conclude that it's a problem at the SipBroker end?

Can someone give me some idea of whats going on? Or if it is a problem with Sipbroker so I can stop trying to fix it my end and just wait?

Any help appreciated.

emoci 12-12-2008 04:57 AM

Curious, have you tried an alterante access number...

vk4akp 12-12-2008 05:34 AM

Alternate number and other idea's.
Hi, Thanks for getting back to me.

OK. The plot thickens!!! I just tried the Sydney gateway and it failed to pass DTMF also. But I tried a USA Sipbroker gateway and it worked!

I also note that if I call a Asterisk system in the USA that I am involved with from the Brisbane gateway the DTMF works. Yet his system and mine both share the same settings in sip.conf .

The strange thing is that DTMF always used to work and then all of a sudden stopped working. As there had been no changes here I could only assume the problem was elsewhere. (Although I know better never to deal in absolutes when it comes to computers). :)

Now here's another interesting test. I had friends dial into my box using SIP and also using a USA Gateway I have for the box (IPKall) and that all worked fine also. If I dial out from my ata using VoXaLot and loop back into the Asterisk box once again it works fine.

All very strange. (And annoying) hehe.

The problem seems to only exist from a AU Sipbroker gateway to a AU Asterisk Box. Go figure !! ??? ¿¿¿ :|

vk4akp 01-16-2009 01:52 PM

Sipbroker test numbers
Here's some numbers for you guys to do some testing with from the .AU gateways.

*061 742 926 (My asterisk system [ in Queensland .AU] )

You will find the DTMF fails.

*8313 00 (Telephreak USA)

You will find the call drops out after a few seconds every call.

This problem has now existed several months.


vk4akp 01-27-2009 03:27 PM

Action need please! PLease reply...
Bump... Bump... Bump...

Hi Guys, can we get some sort of feedback on this problem please?

It is now a very long term issue we need to solve.

Also when dialing the USA system now through the .AU sipbroker gateways the call drops and the channel is hung every time after the first few seconds.

There is obviously an issue with the .AU only Sipbroker gateways.

Can we get some feedback, idea's anything please.

I am more then happy to test any settings you suggest.

Or if this is a known issue with Sipbroker .AU gateways can we at least please get some info.


oman181 06-09-2009 05:17 AM

any action would be nice.... a response maybe?

MarkosJal 06-10-2009 06:20 PM

I think it is asterisk 1.4 and earlier that has DTMF RFC2833 issues. You can google this to check it

Also you make no mention of the asterisk configuration, whether on a public IP or behind a NAT, as I have seen firewalls , NATs, routers that seem to hinder DTMF (I can not explain WHY)

wavesound 09-21-2009 07:13 PM

This was a bug affecting outbound SIP calls in Asterisk 1.4 and 1.6. This issue has been fixed in their latest builds.


An upgrade should resolve your issues. Otherwise, you can specify dtmfmode=inband on your outbound trunks and force G.711u. However, this didn't work very well in my experience.

vk4akp 09-21-2009 08:29 PM

Actually this problem seems to relate to some issue with VoXaLot / SipBroker.

We tried creating some new accounts with both.

We found that without changing anything on the Asterisks machines that some accounts would work ok, yet others would drop out the call after a few seconds or the DTMF would not work.

All very strange but basically nothing can be fixed at the outside Asterisk end.

The accounts that fail need to be looked at the VoXaLot / SipBroker end.


All times are GMT. The time now is 09:34 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.