Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (https://forum.sipbroker.com/index.php)
-   Voxalot Support (https://forum.sipbroker.com/forumdisplay.php?f=4)
-   -   Can't call any German Toll Free numbers through Voxalot (https://forum.sipbroker.com/showthread.php?t=2279)

gambrinus 09-16-2007 07:56 PM

Can't call any German Toll Free numbers through Voxalot
 
Hello,

I'm facing a problem dialling German toll free numbers (49800xxxxxxx) when using ENUM lookup in a Voxalot dialling rule. All toll free numbers resolve to sip:49800\1@sip.pbx-network.de

The error message I get is
407: Proxy Authentication required

My first thought was that pbx-network.de requires authentication and provides the termination of these calls only to their customers, so I posted to the e164.org forum about this issue.

German Toll-Free Numbers: ENUM resolves to sip:49800\1@sip.pbx-network.de

evilbunny, the mod of this forum, whom I also sent a logfile showing this error message pointed out that the root cause must be within Voxalot.

When calling the toll free number directly (sip:49800xxxxxxx@sip.pbx-network.de) the call wents through properly.

Now my question to the Voxalot Team:
Can you find out the root cause for this issue?

Here is the trace:
Code:

20:35:48,668: R: 85.17.19.194:5060 (UDP)
SIP/2.0 407 Proxy Authentication Required
Via: SIP/2.0/UDP 91.65.142.163:62961;branch=z9hG4bK8043384ff162dc118388005056c00001;rport=62961
From: XXXX XXXX <sip:77xx60@voxalot.com>;tag=752182771
To: <sip:49800xxxxxxx@sip.pbx-network.de>;tag=83b87204c57d64485dbe3bb7601319d3.ba9b
Call-ID: 8043384F-F162-DC11-8387-005056C00001@91.65.142.163
CSeq: 13 INVITE
Proxy-Authenticate: Digest realm="voxalot.com", nonce="46ed78b65994af68d96e87e08f0b71513c17013d"
Server: OpenSer (1.1.0-notls (i386/linux))
Content-Length: 0
Warning: 392 85.17.19.194:5060 "Noisy feedback tells:  pid=20805 req_src_ip=91.65.142.163 req_src_port=62961 in_uri=sip:49800xxxxxxx@sip.pbx-network.de out_uri=sip:49800xxxxxxx@sip.pbx-network.de via_cnt==1"

Thanks for your efforts,
cheers, gambrinus.

martin 09-16-2007 11:07 PM

The authentication digest is "voxalot.com" which means that Voxalot is challenging your end point for credentials.

If you look at the "From" address it is a voxalot.com URI

My first question is whether or not your ATA / Device is authenticating with the Voxalot server properly?

Quote:

Originally Posted by gambrinus (Post 12691)
Hello,

I'm facing a problem dialling German toll free numbers (49800xxxxxxx) when using ENUM lookup in a Voxalot dialling rule. All toll free numbers resolve to sip:49800\1@sip.pbx-network.de

The error message I get is
407: Proxy Authentication required

My first thought was that pbx-network.de requires authentication and provides the termination of these calls only to their customers, so I posted to the e164.org forum about this issue.

German Toll-Free Numbers: ENUM resolves to sip:49800\1@sip.pbx-network.de

evilbunny, the mod of this forum, whom I also sent a logfile showing this error message pointed out that the root cause must be within Voxalot.

When calling the toll free number directly (sip:49800xxxxxxx@sip.pbx-network.de) the call wents through properly.

Now my question to the Voxalot Team:
Can you find out the root cause for this issue?

Here is the trace:
Code:

20:35:48,668: R: 85.17.19.194:5060 (UDP)
SIP/2.0 407 Proxy Authentication Required
Via: SIP/2.0/UDP 91.65.142.163:62961;branch=z9hG4bK8043384ff162dc118388005056c00001;rport=62961
From: XXXX XXXX <sip:77xx60@voxalot.com>;tag=752182771
To: <sip:49800xxxxxxx@sip.pbx-network.de>;tag=83b87204c57d64485dbe3bb7601319d3.ba9b
Call-ID: 8043384F-F162-DC11-8387-005056C00001@91.65.142.163
CSeq: 13 INVITE
Proxy-Authenticate: Digest realm="voxalot.com", nonce="46ed78b65994af68d96e87e08f0b71513c17013d"
Server: OpenSer (1.1.0-notls (i386/linux))
Content-Length: 0
Warning: 392 85.17.19.194:5060 "Noisy feedback tells:  pid=20805 req_src_ip=91.65.142.163 req_src_port=62961 in_uri=sip:49800xxxxxxx@sip.pbx-network.de out_uri=sip:49800xxxxxxx@sip.pbx-network.de via_cnt==1"

Thanks for your efforts,
cheers, gambrinus.


gambrinus 09-17-2007 09:40 AM

Hi Martin,

thanks for your quick response. I'll quickly explain how to reproduce the issue. This is my setup:
  1. Setup an ATA to register with Voxalot.
  2. Create a dial plan:
    Pattern: _0800.
    ENUM Lookup: 49${EXTEN:1}
  3. Test dial plan with any 0800xxxxxxx number (this is how you would dial the number if based in Germany). You will get:
    A call to:08001234567 will get forwarded to sip:498001234567@sip.pbx-network.de

    Also see: ENUM lookup result: 498001234567
  4. Dial 08001234567 using your ATA. You will get a fast busy tone and a 407 (Proxy authentication required) in the log.
And yes, the ATA is properly registering with Voxalot...

Any ideas? I have cancelled my fixed line, it will be switched off on Friday... If needed for testing: I own such a German toll-free number, but it is already registered with e164.org and the SIP-Route points to my Voxalot account, so it is currently the only number that works for me... :-(

Thanks for your efforts,
gambrinus

gambrinus 09-19-2007 08:50 PM

Any ideas? :(

martin 09-19-2007 10:51 PM

Quote:

Originally Posted by gambrinus (Post 12752)
Any ideas? :(

Just tried this scenario using x-lite and after dialing:

08001234567

I got a German announcement repeated twice followed by one in english:

"The number you have called is not in service. Please check the number and try again"

Very interesting. From the same ATA does dialing *393613 get you to the FWD echo test OK?

Does 18005551212 get you to the TellMe directory assistance?
.

gambrinus 09-21-2007 06:34 PM

Hi Martin,

Quote:

Originally Posted by martin (Post 12758)
Very interesting. From the same ATA does dialing *393613 get you to the FWD echo test OK?

Yes.

Quote:

Originally Posted by martin (Post 12758)
Does 18005551212 get you to the TellMe directory assistance?

Yes, although I have to dial 0018005551212 (since I have setup Voxalot Dial Plans according to German numbering plan; 00 is the access code for international calls).

When testing this number at the Dial Plan Test I get: A call to:0018005551212 will get forwarded to sip:18005551212@tf.voipmich.com

So ENUM generally works for me and I use it very often since I've registered all my family and friends numbers with e164.org

Just with German Toll Free numbers I still get the 407 Proxy authentication required error message, both using softphones (Gizmo, PhonerLite, X-Pro) and my ATA. When registered to my Voxalot account even when dialling the SIP URI (sip:498003301000@sip.pbx-network.de) I get the 407 message!

I'm really running out of ideas...

Maybe it makes sense to have a look at the server log files to see what's happening.

Thanks a lot for your assistance,

gambrinus

martin 09-21-2007 10:45 PM

Quote:

Originally Posted by gambrinus (Post 12802)
Maybe it makes sense to have a look at the server log files to see what's happening.

Looks like we might have to. This level of debugging however requires live interactive debugging as we don't log all the SIP traffic in production.

I will send you a PM with some additional details.

Thanks.
.

gambrinus 11-13-2007 02:24 PM

For the benefit of everyone:
With joint efforts (thanks to Martin from Voxalot and Lorenz from PBX-network!) we finally found the reason for this issue (affecting all proxy services, not Voxalot only):

If a PBX-network customer registers his account with a proxy service all other users of this service will be challenged for authentification (407), which of course will fail.

PBX-network will workaround this issue in the next few weeks. Will keep you updated.

Regards,
gambrinus

chatalot 11-13-2007 05:13 PM

I know you have a solution coming but I had a similar problem with another freecall provider, have you tried setting up PBX as a VSP in your voxalot account. Put sip.pbx-network.de in as the host name and anything for the username/password as they should not matter.

Now set up a dial plan to route the calls to this VSP. e.g route to 498001234567 and use PBX VSP as you set up earlier. Turn off enum on the dial plan. Not promising it will work but worth a try

gambrinus 11-14-2007 12:51 PM

Well I have a working route for 49800 but others might not. That's why I try to solve the problem at its root. For everyone.


All times are GMT. The time now is 10:31 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.