Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (https://forum.sipbroker.com/index.php)
-   Voxalot Support (https://forum.sipbroker.com/forumdisplay.php?f=4)
-   -   provider details - remote domain needed (https://forum.sipbroker.com/showthread.php?t=1166)

v164 03-03-2007 02:13 PM

provider details - remote domain needed
 
When adding a new provider in the advanced "Provider Details" page,

http://www.voxalot.com/action/providerAdvanced


there is space for the "From Domain", but nowhere to specify the "remote domain".

My Japanese VSP requires the request URI to contain the Japanese-domestic formatted phone number (I can take care of that with VoXaLot dial plans), as well as a VSP-specific "domain". This "domain" is private to the VSP; it cannot be looked up in public DNS (either by A records or SRV records).

eg, the VSP's SIP server is sip.voipexample.jp, but they require the request URI to be in the form:

03xxxxxxxx@privatedomain.voip.vsp

and the SIP INVITE message sent to sip.voipexample.jp


Is there anyway I can get VoXaLot to use the required "remote domain" when sending calls to this provider?

RFC 3261 mentions the ";maddr=..." parameter, which can suffix a SIP URI to indicate a server that must be traversed. Could I somehow specify that suffix in a dial plan rule?

v164 03-21-2007 01:34 PM

remote domain
 
Here are the specific details:

Fusion's SIP proxy server and register server is

ph2.so-net.ne.jp ( 202.238.94.183 )

For outgoing calls, the SIP INVITE packet needs to be sent to their SIP proxy server in this format (for a call to a Tokyo (03)xxxx xxxx number):

Code:

INVITE sip:03xxxxxxxx@0038.fu1.so-net.ne.jp SIP/2.0
Via: SIP/2.0/UDP xxx.xxx.xxx.xxx:6080;rport;branch=z9h...D123
From: 050xxxxxxxx <sip:FUxxxxxxxx@ph2.so-net.ne.jp>;tag=802812810
To: <sip:03xxxxxxxx@0038.fu1.so-net.ne.jp>
Contact: <sip:FUxxxxxxxx@xxx.xxx.xxx.xxx:6080>
Call-ID: DD1B....4C66@192.168.11.55
CSeq: 64733 INVITE
Max-Forwards: 70
Content-Type: application/sdp
User-Agent: X-PRO build 1101
Content-Length: 195

Note that the domain in the "From: " header is the FQDN of the SIP proxy server, however the domain in the request URI is 0038.fu1.so-net.ne.jp. It is possible to enter this with a softphone, however I can't see any way to make such a call through Voxalot.

There is nowhere to enter a "remote domain" in the Provider Details page.

In creating the request URI, VoXaLot dial plans would take care of creating the part to the left of the "@", but I need some way to specify the part to the right of the "@".

Currently, VoXaLot would send a call to Fusion like this:

Code:

INVITE sip:03xxxxxxxx@ph2.so-net.ne.jp SIP/2.0
which doesn't work.


All times are GMT. The time now is 12:59 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.