PDA

View Full Version : Dial Plan Replacement Value


Ron
03-27-2006, 01:25 PM
Why can't the replacement field value in a Dial Plan be a literal string?

I would like to be able to dial 411 and have it go off to FWD as *18007270986. I tried to be clever with ${EXTEN:3}*18007270986, which is accepted, but dialing 411 always get a fast busy.

wmp
03-27-2006, 04:39 PM
I think the problem may be with the 411 part and not the replacement. I tried *${EXTEN:2}8007270986 as the replacement and it came out as valid under number to test. However, when dialing from the phone I get a fast busy.

Here is an option I verified as working. Set 411 as the Speed Dial number and in the SIP URI enter sip:*18007270986@fwd.pulver.com. Then just dial **411. Not as elegant as simply dialing 411, but it works.

Ron
03-28-2006, 01:29 AM
Speed dial would be an option, but I don't see any reason NOT to allow literal strings as the replacement value, expecially since you're allowed to apply prefixes and suffixes to ${EXTEN}. It appears the problem is simply a validation check issue on the web page form.

wmp
03-28-2006, 03:01 AM
Here's another option that works. Using the Dial Plan on my SPA2000 I added <411:*18007270986><:@fwd.pulver.com> as the first entry. Of course this skips Voxalot, but using this method allows you to just dial 411.

Ron
03-28-2006, 03:50 AM
Here's another option that works. Using the Dial Plan on my SPA2000 I added <411:*18007270986><:@fwd.pulver.com> as the first entry. Of course this skips Voxalot, but using this method allows you to just dial 411.

Yes, I'm aware of all these work-arounds, but they don't get the bugs worked out of VoXaLot :) .

martin
03-28-2006, 08:05 AM
Yep it is a validation bug that we will fix. Thanks for letting us know.

martin
03-29-2006, 11:55 AM
Guys this should now be fixed. Please advise.

Ron
03-29-2006, 12:32 PM
Martin,

The validation problem is gone, but it doesn't produce the correct results.

My dial plan is:

_4111 *18003733411 Free World Dialup

and the test is:

A call to:4111 will get forwarded to sip:4111@fwd.pulver.com.

It appears it's totally ignoring the subsitution operation.

Ron

martin
03-29-2006, 09:53 PM
Hmm it appears the corresponding SIP proxy change was not deployed. Can you please retry?

Ron
03-29-2006, 11:17 PM
Both the web page test and actual dialing appear to be working properly now.

Thank you.

Ron