PDA

View Full Version : VoXaLot Performance Tuning - Phase 1


martin
07-01-2006, 07:33 AM
Due to a big increase in member numbers we have noticed a couple of performance issues around outgoing calls.

This morning we released phase 1 of these performance tuning enhancements.

Interested in your feedback.

Ron
07-01-2006, 09:41 AM
Outgoing call setup time appears to be further improved. Worst case is now 3 seconds, with the average time being 2 seconds, for the destination phone to start ringing. That's testing across five providers to a PSTN destination.

Ron

wildbill
07-02-2006, 12:47 AM
Agree quicker now about 4 secs before ring here - Bill

hisybr
07-03-2006, 12:35 AM
We are finding that our calls often don't go through at all. Mostly using SipPhone or GizmoProject to ring US in AM Australian hours, however, also using AstraTel to call interstate throughout the day. Just get lots of silence until it times out to busy signal.

Just tried several times, all of the above providers, with varying waits to time out. No success connecting on any provider. Even tried initiating call through SipPhone web page. Rang my ATA connected phone OK (so found me through VoXaLot registration, but again, silence to time out making the other half of the call.

The concept is great, but performance seems to be very problematic. Oversubscribed?

hisybr
07-03-2006, 01:13 AM
Hi,

Right after my last post, where I timed out for all three providers, I unregistered one of my services on VoXaLot, and then reset my ATA from VoXaLot (.com.au) to another provider. Called out on them direct without any problems at all.

So, call initiation problems definitely seem to be on the VoXaLot end. As our calls have been going though OK sometimes, does not seem to be a settings problem on our end. General feedback is that daytime (Australia) is worse than evening in terms of getting through. Oversubscribed? Would it be any better if I switched to .com instead of .com.au?

Cheers, Brian

martin
07-03-2006, 04:00 AM
Thanks for the feedback. We are interested in other peoples experiences also?

wildbill
07-03-2006, 06:04 AM
Martin - a long delay now approx 15 seconds before ringing - also SPA monitor now says Dialling Stunning Calling then displaying the called number - this didnt happer before (Stunning) - Bill

affinity
07-03-2006, 06:19 AM
I have a test ATA that was able to make calls behind a NAT firewall using a STUN server last night, but today I have no audio incoming.... my 7402VGO is working fine both ways, but not the test ATA [even though it did last night...]

martin
07-03-2006, 06:42 AM
Bill and affinity How is the RTP/STUN now?

wildbill
07-03-2006, 06:57 AM
Martin still getting delay - speed improved slightly (about 11secs) also 600 takes about 8 secs to answer where it was almost instantaneous before - Bill

affinity
07-03-2006, 06:59 AM
Still no incoming audio....

- although I got a partial succes trying *393613, it started to ring, but then gave engaged signal.

hisybr
07-03-2006, 07:54 AM
Hi,

Just switched the ATA back to Voxalot.com.au and placed a call through AstraTel. Minimal delay (1-3 sec). Any correlation between traffic loads and my problems at 11:00 AM compared to smooth function now? Or, did you guys tweak something.

Cheers, Brian

wildbill
07-03-2006, 08:14 AM
Martin - ring back from FWD call me rings but no audio and eventually to Msgbank and E164 enum test no call back - still with about 8 sec delay on outgoing to *393613 - Bill

affinity
07-03-2006, 10:06 AM
I now have audio back.... no changes here. Fairly long delays before call connects though.

martin
07-03-2006, 10:10 AM
Our RTPProxy was playing up so we installed a new one.

Please define what fairly long delays are as our metrics here suggest 3 sec turnarounds with this new proxy?

affinity
07-03-2006, 10:24 AM
Our RTPProxy was playing up so we installed a new one.

Please define what fairly long delays are as our metrics here suggest 3 sec turnarounds with this new proxy?
It seems to have improved.

600 echo test 4 to 8 seconds....
VM about 7 to 16 seconds until I get the first audio, saying "login incorrect" -- enter my PIN then and its fine.
ENUM call 5 seconds, called phone rings only once :(
*393613 call 3 to 5 seconds
*266300 call 3 to 7 seconds

martin
07-03-2006, 10:28 AM
Considering the amount of processing we are doing behind the scenes those numbers appear to be within limits.

I am more concerned with your ENUM problem though

If you dial plan allows this ENUM number, can you try:

18005551212?

Thanks

affinity
07-03-2006, 10:47 AM
The 1800 ENUM test worked fine.

I called my 618705xxxx number from a voxalot registered ATA using a STUN server behind NAT. My 7402VGO range once only -- I have repeated this quite a few times.

EDIT: 6138705xxxx (I did use the correct numbers....)

affinity
07-04-2006, 01:20 AM
The single ring problem occurs under this circumstance:
- ATA phone using STUN behind a NAT SPI firewall
- 7402VGO attached phone [registered FXS port]
- calling from the ATA and dialing either the ENUM number or straight voxalot number is the same.

If I dial from the 7402VGO [either the ENUM number or my voxalot number], then the ATA will ring fine, but the 7402VGO will have no audio.

If I call from the 7402VGO to the same voxalot number, then the ATA rings, but no audio travels between the calls.

The combination of STUN and no STUN on the same call between the same voxalot numbers seems to be the problem.

wildbill
07-04-2006, 03:01 AM
Martin - call to 18005551212 works after a 8-10 sec delay - no luck now with FWD call me and Enum test at E164org rings but no audio when answered - Bill

BBD
07-05-2006, 04:27 AM
i'm not sure if this has anything to do with the performance tuning, but for the last few weeks i have been unable to hear anything when i call out through Pennytel. the person on the other end can just hear buzzing and i cannot hear anything.

has anyone else had this issue?