Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > SIP Broker Forums > SIP Broker Support

SIP Broker Support Support for the SIP Broker service.

 
 
Reply
Thread Tools Display Modes
Unread 10-12-2010, 08:02 AM   #1
dyg
Junior Member
 
Join Date: Oct 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
dyg is on a distinguished road
Unhappy Problem using Linphone

I have installed Linphone 3.2 into 2 PCs which both were using Ubuntu 8.
PC A with the IP address 192.168.1.10 - alice@open.my
PC B with the IP address 192.168.1.20 -bob@open.my
Then, I try to make calls between both parties and it looks success.

but the problem is,
when i refer on the wiresharks,
within the Message Header of the SIP it shows alice@127.0.0.1 or bob@127.0.0.1 instead of their own ip address; alice@192.168.1.10 or bob@192.168.1.20.


How can i modify the 127.0.0.1 into their own ip address because in certain process, 127.0.0.1 may cause some problems (it keep looping on itself and fails out other process) . I've made some changes either on the hostname,resolv.conf,dns etc..but still showing the 127.0.0.1

I'm not sure the problem may cause by the linphone itself or the Operating System or even Network configuration.
Anyone can help me ??since i'm new in this situation.

Thanks..
Regard ,dyg
dyg is offline   Reply With Quote
Unread 11-06-2010, 07:55 PM   #2
padboll
Member
 
Join Date: Dec 2006
Location: Belgium
Posts: 40
Thanks: 4
Thanked 1 Time in 1 Post
padboll is on a distinguished road
Default

Be careful, SIP is not an easy protocol and headers can contain tricky informations that may appear wrong but are used for something else...

I think you should play with parameters in Linphone preferences: I noticed that header content and strange behaviors are related to a particular interpretation of Linphone preferences. Take a look at the firewall settings (direct/public/STUN which gave me problems in the past) and the "default identity" in accounts menu.
(Last time I used it, I used STUN even if not required because of my strict router with strange SIP ALG behaviors. I have a special configuration and thus cannot tell you more for a normal situation...)

I also had to create a dummy account with identity "sip:1234@192.168.123.45" so as to be available in the main GUI, below, in the listbox where you can select which account you want to use... Maybe this is what you are looking for.
padboll is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with complex problem elleff Voxalot Support 0 06-27-2007 01:16 PM
Incoming call problem pironato Voxalot Support 18 06-21-2007 11:25 AM
Strange loopback problem tuttle Voxalot Support 1 02-12-2007 02:58 AM
Is any Problem with Voxalot Service now? shibukraj Voxalot Support 8 11-05-2006 07:07 PM
Pennytel, Buzz problem Nathanc Voxalot Support 17 06-28-2006 12:20 AM


All times are GMT. The time now is 01:30 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.