Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 05-23-2010, 11:30 AM   #11
padboll
Member
 
Join Date: Dec 2006
Location: Belgium
Posts: 40
Thanks: 4
Thanked 1 Time in 1 Post
padboll is on a distinguished road
Default

Hi.
Each time I got something like this, it was related in a way with NAT/STUN.

I don't know the SPA2100. Do you really need to change the port from 5060 to something else? In the different hardware I got until now, this is the smartness of the device to forward calls to correct line according to phone number (SIP uri).
And each time I tried to play with ports on a "smart" device, I got problems of that kind...

If your main router has SIP ALG feature, you don't even need STUN and won't have NAT problem, except if you change port.
If your main router is not SIP aware, then you need to forward ports (worst case) or use STUN (better).

So, since your JustVoip is playing well, I would suggest to go back with port 5060 and stun.voxalot.com. (And no port forwarding on NAT!)
If it still fails, take a look at options "handle symmetric NAT" and "optimize audio path" in your Voxalot account. (I'm pretty sure that those two options are not concerned, but anyway...)
padboll is offline   Reply With Quote
Unread 06-04-2010, 02:14 AM   #12
tatjam
Member
 
Join Date: May 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
tatjam is on a distinguished road
Default

In renewed testing, so far every time I get MOCS when using line 1 (voxalot registration with justvoip set as VSP), if I immediately call back the same number using line 2 (direct registration with justvoip, not using voxalot as an intermediary), the call terminates normally: I can hear the party I'm calling just fine, and they can hear me. Furthermore, MOCS seems to be happening more frequently on line 1 (voxalot registration with justvoip set as VSP). Today, all calls I tried on line 1 resulted in MOCS: I could hear the party/system I was calling just fine, but they could not hear me. This seems to point to some problem with voxalot or with my voxalot configuration, does it not?

Will continue with testing and posting results.

James
tatjam is offline   Reply With Quote
Unread 06-04-2010, 02:46 AM   #13
tatjam
Member
 
Join Date: May 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
tatjam is on a distinguished road
Default

Quote:
Originally Posted by padboll View Post
Each time I got something like this, it was related in a way with NAT/STUN.

I don't know the SPA2100. Do you really need to change the port from 5060 to something else? In the different hardware I got until now, this is the smartness of the device to forward calls to correct line according to phone number (SIP uri).
And each time I tried to play with ports on a "smart" device, I got problems of that kind...

If your main router has SIP ALG feature, you don't even need STUN and won't have NAT problem, except if you change port.
If your main router is not SIP aware, then you need to forward ports (worst case) or use STUN (better).

So, since your JustVoip is playing well, I would suggest to go back with port 5060 and stun.voxalot.com. (And no port forwarding on NAT!)
If it still fails, take a look at options "handle symmetric NAT" and "optimize audio path" in your Voxalot account. (I'm pretty sure that those two options are not concerned, but anyway...)
Thanks for your input, which I am considering. Line 1 (voxalot registration with justvoip as VSP) is set to use port 5060. Line 2 (direct justvoip registration) I set to use port 5061. I do currently have stun.voxalot.com:3478 set as my STUN server. My router (wrt54g flashed with dd-wrt) is not SIP-aware--at least not the firmware version I currently have on it. Anyway, in addition to having the STUN server set on my ATA, I also set port forwarding on my router: it currently forwards port 5060, 5061, 5082, 4569, and 3478 to the ATA. Still thinking . . .

James
tatjam is offline   Reply With Quote
Unread 06-04-2010, 11:44 AM   #14
padboll
Member
 
Join Date: Dec 2006
Location: Belgium
Posts: 40
Thanks: 4
Thanked 1 Time in 1 Post
padboll is on a distinguished road
Default

Since the router is not SIP aware, you have two possibilities:
- using STUN without port forwarding (direct call from outside not possible)
- using port forwarding (5060 + audio stream dynamic ports) without STUN

If you mix port forwarding and STUN, you'll have troubles... (Even if sometimes it works fine, it is not reliable and can behave differently from call to call).
I would first test with only STUN, removing all forwarding rules from NAT.
You can also use the STUN from JustVoip with Voxalot account, I already got some compatibility issues with the one from Voxalot in the past.

If STUN still fails, this is probably because of your NAT which is badly implemented or is symmetric. But since your JustVoip account works fine, I don't think so.
padboll is offline   Reply With Quote
Unread 06-04-2010, 03:11 PM   #15
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by tatjam View Post
Thanks for your input, which I am considering. Line 1 (voxalot registration with justvoip as VSP) is set to use port 5060. Line 2 (direct justvoip registration) I set to use port 5061. I do currently have stun.voxalot.com:3478 set as my STUN server. My router (wrt54g flashed with dd-wrt) is not SIP-aware--at least not the firmware version I currently have on it. Anyway, in addition to having the STUN server set on my ATA, I also set port forwarding on my router: it currently forwards port 5060, 5061, 5082, 4569, and 3478 to the ATA. Still thinking . . .

James
As far as forwarded ports....also add the RTP range that your ATA uses...in Linksys models you can find this under the SIP Tab I believe...
(The range in my PAP2 and SPA3102 was 16384-16482)

One other thing to try:
In VoXalot:
-Under Member page set Symmetric NAT to No,
Under provider settings (for JustVoip):
-Set Optimize Audio to Yes
-Set your codecs to:
ulaw;alaw;g726;g729;ilbc;gsm

Reboot your ATA after making those changes...
emoci is offline   Reply With Quote
Unread 06-05-2010, 01:58 PM   #16
tatjam
Member
 
Join Date: May 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
tatjam is on a distinguished road
Default

Quote:
Originally Posted by padboll View Post
Since the router is not SIP aware, you have two possibilities:
- using STUN without port forwarding (direct call from outside not possible)
I still get MOCS on line 1 (voxalot registration with justvoip set as VSP), even with port forwarding turned off but the STUN server still set.
Quote:
- using port forwarding (5060 + audio stream dynamic ports) without STUN
I get MOCS on line 1 with this setup, too. Whether the STUN server is set or not (with port forwarding activated), the problem persists.
Quote:
You can also use the STUN from JustVoip with Voxalot account, I already got some compatibility issues with the one from Voxalot in the past.
I tried changing the STUN server back to justvoip and I still get MOCS on line 1.
Quote:
If STUN still fails, this is probably because of your NAT which is badly implemented or is symmetric. But since your JustVoip account works fine, I don't think so.
That's the confusing part: why does line 2 (direct registration with justvoip, not using voxalot as an intermediary) seem to work fine every time (no MOCS), while line 1 has those problems? In fact, every call I've tried to make over the last 2 days on line 1 has resulted in the MOCS problem. Hmmm . . .

I took the radical step of upgrading my router's firmware, thinking that might influence the issue, but it seems to be having no effect. I still get MOCS with each call I try to make using line 1.

I also wondered whether it might have to do with the fact that line 2 is registering my justvoip account, so that account somehow becomes dysfunctional when I'm trying to use it via voxalot. But if that were the case, I don't see why I'd be able to use it at all, i.e., why I could even make an outgoing call (being able to hear the party I'm dialing, while they can't hear me). Strange.

Then, there's one of the main reasons I even bothered to set up line 2 to register directly with justvoip: I was, in part, trying to eliminate the FUP exceeded charges I was seeing on my justvoip account. Setting up line 2 like that and using it to make calls to the PSTN does seem to have resolved the extraneous FUP exceeded charges, by the way. And I should also mention, if I haven't already, that I sometimes get MOCS when calling another voxalot user (i.e., not using any VSP), and he sometimes gets MOCS when calling me (again, no VSP involved). That indicates the problem lies with voxalot or with the way my/his hardware (different hardware, btw) is/is not interacting with the voxalot servers.

I still don't see where the problem lies here. But I intend to keep testing and searching for a solution.

James

Last edited by tatjam; 06-05-2010 at 05:29 PM. Reason: correction
tatjam is offline   Reply With Quote
Unread 06-05-2010, 02:06 PM   #17
tatjam
Member
 
Join Date: May 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
tatjam is on a distinguished road
Default

Quote:
Originally Posted by emoci View Post
As far as forwarded ports....also add the RTP range that your ATA uses...in Linksys models you can find this under the SIP Tab I believe...
(The range in my PAP2 and SPA3102 was 16384-16482)
Thanks for your input, emoci. I checked my router and that range of ports has been forwarded all along--I didn't need to change anything there.

Quote:
One other thing to try:
In VoXalot:
-Under Member page set Symmetric NAT to No,
Under provider settings (for JustVoip):
-Set Optimize Audio to Yes
-Set your codecs to:
ulaw;alaw;g726;g729;ilbc;gsm

Reboot your ATA after making those changes...
I tried these settings and rebooted the ATA. Optimize audio was already set to "yes." Even with the settings at the values you recommend and a reboot, I still get MOCS on line 1 (registration with voxalot, justvoip set as VSP): I can hear the party I'm calling perfectly well, but they can't hear me (or detect keystrokes if I'm dialing an automated system that expects me to enter numbers).

I'm open to further suggestions--including the possibility that I'm doing something very basic wrong. I don't claim to possess a thorough understanding of VOIP.

James
tatjam is offline   Reply With Quote
Unread 06-05-2010, 02:32 PM   #18
padboll
Member
 
Join Date: Dec 2006
Location: Belgium
Posts: 40
Thanks: 4
Thanked 1 Time in 1 Post
padboll is on a distinguished road
Default

The last thing I could recommend to test is another modem-router, the most basic you can find around, without port forwarding and with STUN on your ATA.

What you described looks so much to NAT/STUN issues that I would insist on testing around this point. Why? Because the problem occurs on incoming audio stream, exactly what STUN/NAT is involved in... And exactly the kind of issue I've been used to see most of time.

Just one more thing: ensure that both ends have same codecs activated! At least one common, I would suggest alaw(g711a)/ulaw(g711u).
For example: if your device has only g729 activated and your callee has other codec(s) activated but not g729, I think you could get the same result.

While testing, since it also appears from Voxalot to Voxalot, I would continue testing without VSP since it brings some more complexities, thus potential concurrent issues.

Good luck...
padboll is offline   Reply With Quote
Unread 07-22-2010, 06:46 PM   #19
tatjam
Member
 
Join Date: May 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
tatjam is on a distinguished road
Default

I needed to do some further experimentation today owing to a MOCS-like problem: for the first time ever since I've set this up and have been using voxalot, I got mute caller syndrome on an incoming call. That is to say, someone called me and I could hear them speaking, but they could not hear me. This has never happened on an incoming call before to my knowledge. So now I have, not only MOCS, but MICS (mute incoming call syndrome).

I decided it was time to get drastic with my set-up. So I put the ATA in front of the router. Now it--not the router--has the public IP. So my router and the rest of my network is now on a subnet established by the ATA.

The good news is that dyndns seems to work ok on my router, despite the fact that it doesn't have a public IP. The bad news is that this does not resolve the MOCS problem: after I put the ATA in front of the router, i.e., such that it gets the public IP and establishes a private subnet for my router and network (now located behind it) every call I've tried to make using line 1, I get MOCS. Again, line 1 is set to register with voxalot, using a betamax reseller as VSP.

And just as has happened without fail since I've started this new round of testing--regardless of whether the ATA is in front of or behind the router--every call I've made using line 2 has worked pretty much flawlessly: I can hear the party I'm calling just fine, and they can hear me. Again, line 2 registers directly with the betamax reseller, not using voxalot as intermediary.

So, what in the world could be going on here? I think that, by putting the ATA in front of the router, such that it has the public IP, I've effectively eliminated the possibility of NAT issues--have I not? Could it be some kind of weird hardware issue? I suppose that if I switched the configuration of line 1 to be like line 2 and vice versa I might learn something about that.

But anyway, up until today, I believe every incoming call on line 1 (voxalot registration, betamax reseller as VSP) worked normally with respect to the MICS problem: I could always hear the party who was calling me, and they could hear me. But today I got MICS on line 1: I could hear the person calling me, but they could not hear me. And again, every time I've made an outgoing call using line 2 (direct registration with my betamax reseller, with no voxalot intermediary) it worked pretty much flawlessly: I could hear the party I was calling just fine, and they could hear me--and that's regardless of whether the ATA or the router had the public IP.

Further troubleshooting suggestions will be appreciated.

Thanks,
James

PS I just (after having put the ATA in front of the router) received an incoming call on line 1 which worked fine, i.e., there was no MICS issue with this call, unlike the calls that came earlier today.
tatjam is offline   Reply With Quote
Unread 07-23-2010, 02:50 PM   #20
jozef
Member
 
Join Date: Jul 2008
Posts: 46
Thanks: 30
Thanked 12 Times in 11 Posts
jozef is on a distinguished road
Default

Yesterday I called my VOIP-friend and get MOCS. Call was Voxalot -> Voxalot.
Next call to him was thru FreeCall (Betamax) provider. Voxalot -> Freecall 883510004xxxxxx -> Voxalot. Call was disconnected after 30 sec.
I try one more time thru Actio provider. Voxalot -> Actio -> Actio. The call connected and we talked 50 minutes.

Is it Voxalot issue?

Quote:
Originally Posted by tatjam View Post
... As I'm now recalling, one key factor leading me to lean toward that conclusion was the fact that I sometimes get MOCS when I'm calling another voxalot user: in those cases, there can be no question of poor interaction between voxalot and a VSP, since it all goes through voxalot. ...

I would suggest:
1. Try without registration on line 2 with justvoip.
2.1. Try with Sipsorcery or PBXes instead of Voxalot. Justvoip as provider in Sipsorcery/PBXes. Line 2 with direct registration with justvoip.
2.2. Try with Sipsorcery or PBXes instead of Voxalot. Justvoip as provider in Sipsorcery/PBXes. Line 2 without registration with justvoip.
3.1 Try with Sipsorcery or PBXes. Voxalot as provider in Sipsorcery/PBXes and justvoip as provider in Voxalot. Line 2 with direct registration with justvoip.
3.2 Try with Sipsorcery or PBXes. Voxalot as provider in Sipsorcery/PBXes and justvoip as provider in Voxalot. Line 2 without registration with justvoip.

Thanks,
Józef
jozef is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
Call on Betamax usernames visserronald Voxalot Support 7 08-29-2011 09:13 PM
Voxalot and Sipura/ATA Tutorial: A Comprehensive Walkthrough ctylor Voxalot General 5 04-28-2010 12:52 AM
Voxalot + ActionVoip (BetaMax) - Cant make outbound calls shibukraj Voxalot Support 1 10-10-2009 10:52 PM
X-Lite V3 issue - No Outbound voice on Inbound Call LeonB Voxalot Support 1 01-20-2009 03:31 AM


All times are GMT. The time now is 02:45 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.