Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot General

Voxalot General Voxalot discussion, tips, tricks and suggestions. Talk about them here.

 
 
Reply
Thread Tools Display Modes
Unread 08-27-2007, 02:18 PM   #11
voip2007
Member
 
Join Date: Jun 2007
Posts: 64
Thanks: 14
Thanked 2 Times in 2 Posts
voip2007 is on a distinguished road
Default

Quote:
Originally Posted by kurun View Post
Have you checked if the DIDs are working correctly?

Yesterday, I needed a DID for testing and I used a DIDWW test number using the Midle East server and it was not working.
The test using the US server worked fine.
Just a thought ......
I am using US server. I didn't change anything. The problem is starting from yesterday 1:30pm in montreal.
voip2007 is offline   Reply With Quote
Unread 08-27-2007, 08:32 PM   #12
oleras
Junior Member
 
Join Date: Mar 2007
Location: Melby, Denmark
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
oleras is on a distinguished road
Default

Quote:
Originally Posted by martin View Post
Ole,

Where is the inbound call coming from?
.
Hi Martin

It comes from: Musimi.dk
__________________
--
/Ole
oleras is offline   Reply With Quote
Unread 08-27-2007, 10:55 PM   #13
voip2007
Member
 
Join Date: Jun 2007
Posts: 64
Thanks: 14
Thanked 2 Times in 2 Posts
voip2007 is on a distinguished road
Default

Quote:
Originally Posted by oleras View Post
Hi Martin

It comes from: Musimi.dk
hi, oleras. I fixed the problem. I think it is because the stun server changed. now you have to use stun.voxalot.com au:3478. For my case, I changed to it, it right away work perfectly. But I don't understand I use my original one for 3months. there is no any problem. it was just starting yesterday the old one doesn't work for voxalot system. Maybe it is because voxalot upgraded the system.
good luck
voip2007 is offline   Reply With Quote
Unread 08-29-2007, 06:26 AM   #14
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Quote:
Originally Posted by voip2007 View Post
it was just starting yesterday the old one doesn't work for voxalot system. Maybe it is because voxalot upgraded the system.
good luck
old one? not sure what you mean by this?

The IP address changed 2 weeks ago, is this what you are referring to?
.
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Unread 08-31-2007, 06:23 PM   #15
voip2007
Member
 
Join Date: Jun 2007
Posts: 64
Thanks: 14
Thanked 2 Times in 2 Posts
voip2007 is on a distinguished road
Default

Quote:
Originally Posted by martin View Post
old one? not sure what you mean by this?

The IP address changed 2 weeks ago, is this what you are referring to?
.
No, martin. I mean the old stun server which I used before. It used to work perfectly, but just a few days ago, suddenly I can't receive the phone call. But after I changed the stun server into stun.voxalot.com, the income call came back.
voip2007 is offline   Reply With Quote
Unread 08-31-2007, 08:37 PM   #16
oleras
Junior Member
 
Join Date: Mar 2007
Location: Melby, Denmark
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
oleras is on a distinguished road
Default

Quote:
Originally Posted by voip2007 View Post
hi, oleras. I fixed the problem. I think it is because the stun server changed. now you have to use stun.voxalot.com au:3478. For my case, I changed to it, it right away work perfectly. But I don't understand I use my original one for 3months. there is no any problem. it was just starting yesterday the old one doesn't work for voxalot system. Maybe it is because voxalot upgraded the system.
good luck
Hi

Ok, normally it's possible to use any stun server, i use one here in Denmark, but will test stun.voxalot.com.

Well, my problem is that things work perfectly, with sound both ways, f.ex. 3-4 days, and then the 5 day there is no sound on incoming calls, next day again it work ok aso. It's not stable !.

/Ole
__________________
--
/Ole
oleras is offline   Reply With Quote
Unread 09-01-2007, 11:59 AM   #17
lamo
Junior Member
 
Join Date: Jul 2007
Posts: 6
Thanks: 1
Thanked 1 Time in 1 Post
lamo is on a distinguished road
Default Calls from did worldwide not working

I noticed that incoming calls from did worldwide ring but not sound then drop after a few seconds or go to voice mail.
Outgoing calls work fine.
Have been working fine in the past - no changes in set up of my sipura 2000.
Does anyone else notice this.
lamo is offline   Reply With Quote
Unread 09-01-2007, 01:46 PM   #18
voip2007
Member
 
Join Date: Jun 2007
Posts: 64
Thanks: 14
Thanked 2 Times in 2 Posts
voip2007 is on a distinguished road
Default

Quote:
Originally Posted by lamo View Post
I noticed that incoming calls from did worldwide ring but not sound then drop after a few seconds or go to voice mail.
Outgoing calls work fine.
Have been working fine in the past - no changes in set up of my sipura 2000.
Does anyone else notice this.
please read no.13
voip2007 is offline   Reply With Quote
Unread 09-16-2007, 01:23 PM   #19
lamo
Junior Member
 
Join Date: Jul 2007
Posts: 6
Thanks: 1
Thanked 1 Time in 1 Post
lamo is on a distinguished road
Default Incoming from worldwide did nos sound

Quote:
Originally Posted by voip2007 View Post
please read no.13

Thanks - I changed the stun server to "stun.voxalot.com" but get the same negative result.
The phone rings, I pick up and hear some noice but then it hangs up ...does not go to voicemail anymore.
I contacted wwdid and they claim "they tested and the phone rings" and they do not provide further help.
I am using a Sipura 2000 and can make outgoing calls fine (voxalot>voipdiscount.com)
As said it had worked for a few months before stopping.
I could furnish SP2000 config if necessary. Cany anyone assist?
lamo is offline   Reply With Quote
Unread 09-16-2007, 04:27 PM   #20
DracoFelis
 
DracoFelis's Avatar
 
Join Date: Mar 2006
Posts: 188
Thanks: 4
Thanked 64 Times in 41 Posts
DracoFelis is a jewel in the roughDracoFelis is a jewel in the rough
Default

For those of you having problems, how do you have your home router setup for your VoIP?

I'm not sure if it's the problem here. However, it's been my experience that 1-way (and 0-way) audio problems are OFTEN the fault of your home router, that is incorrectly treating the audio stream as an "attack" from the internet, vs properly forwarding it to your VoIP equipment. i.e. in many cases the audio is actually getting to you, but your router (or the router of the person on the other end) is preventing the audio from making it the whole trip between the two VoIP end points.

Now, if the above is what is going on, than there are many settings that could be done to the various VoIP equipment, and probably even a few changes that could be done to VoXaLot, to help convince the routers to "behave". However, such changes are not certain to work, and would really only be "work arounds" away. IMHO the proper "fix" for this (because it's the only "fix" that addresses this issue 100% of the time, because it works directly on problem routers themselves), is to have people configure their routers to always allow this VoIP traffic (and always send it on to their VoIP adapters). And that is usually done with "port forwarding" on your home/NAT router.

Specifically, VoIP is naturally more reliable if/when SIP and RTP ports of the VoIP adapters are exposed to the internet (although you generally do NOT want the web interface of VoIP adapters to be exposed, just the VoIP ports, which is why I usually avoid using the router's DMZ and instead "port forward" the SIP and RTP ports)! The way port forwarding is done varies with your router, and which ports to use varies with which VoIP adapters you have, and how you have them setup. So I can only give general advice on this. However, in general, it should be possible to modify this technique for other adapters and routers, the details will just vary slightly.

1) In general you need to first assign a fixed IP address on your LAN to your VoIP adapter. This is often necessary, so you have a consistent place to tell your router to forward VoIP ports to. Because if you let the router auto-configure based upon DHCP, it might get a different IP address (on your LAN) when you reboot the router, and therefore mess up your attempts to "port forward" (because the adapter has "moved" on your LAN, as it were). This is usually done on your VoIP adapter's "advanced" settings, and you should try to pick a LAN IP address that is part of your LAN (which with a lot of routers means that the 1st three numbers are the same as other devices on your LAN), but which isn't used for any other device on your LAN, and also is not part of the range that your DHCP server (that is often part of your router) auto-assigns to devices (because you will get real network headaches if/when two devices get the same IP address on your LAN).

2) Once you have the VoIP adapter at a fixed LAN address, you can proceed to "forward" the SIP and RTP ports for your adapter, to the IP address (on your LAN) you now have the adapter on. If you already know the UDP ports used (by your VoIP adapter) for SIP and RTP, than you should be good to go. If not, you will have to do some investigation in your VoIP adapter, to find the info.

2a) The SIP port is the port used to setup a call (i.e. ring your phone, and similar issues). It is often UDP 5060, but many adapters will let you set this to other numbers. And even with the "default" settings, many adapters use a different port number for the 2nd/3rd/etc line, than they do for the 1st VoIP line. So it's usually easiest (and most accurate) to get this number (or these port numbers, if your VoIP adapter supports more than one line), by just checking the SIP port settings in your adapter (with many adapters, this info can be seen in the advanced settings of the adapter's web interface).

2b) The RTP port RANGE is the range of UDP ports that can be used for VOICE TRAFFIC. With most adapters, this range is (by default) MUCH bigger than it needs to be. For example, some LinkSys adapters is 16384-16486 (over 100 different ports) by default, and some devices even use 10000-20000 (about 10,000 different ports) by default. IMHO even having 5 times as many ports as you have "lines" in your equipment is over-kill, so you really do NOT need anywhere near as many port options as VoIP adapters like to use "by default". Instead, you can often considerably lower this range (if desired), to give you less ports to "forward" to your adapter. And you can also edit the range, to allow multiple VoIP adapters to exist on your LAN, but with different RTP ports (so you can have your router forward the proper voice traffic to each adapter). I actually did the latter, as I have two VoIP adapters on my LAN (which I have setup with different, non-overlapping RTP port ranges, each properly "port forwarded" to the proper VoIP adapter on my LAN).

NOTE: On many LinkSys adapters, the RTP port range is defined/set on the "SIP tab" (of the web interface of the adapter), as being between the values "RTP port min" and "RTP port max". On other adapters, you will have to consult the adapter's manual to find the RTP port range.

Again, most of the above is often "not necessary", as many routers will often open the required ports dynamically as needed (based upon the actions of the VoIP adapters). However, it is the approach that seems to give the most consistent VoIP results, and therefore the approach I take on my LAN. Because without the above "port forwarding", you are counting on things like the "keep alive" packets from your adapter to keep the call channels open. And that can be "hit or miss" as to if it will work with any given router. But when you explicitly allow all VoIP call traffic to your LAN to be sent to your VoIP adapter (setup technique above), than issues such as "missed calls" (your router blocked the SIP port was blocked when it tried to "ring your phone"), or "1-way audio" (your router blocked the inbound voice from the other end) often go away.

NOTE: And as long as you only open the SIP and RTP ports (and then only to your VoIP adapter), you really aren't lowering your internet security much. But such an approach will give inbound VoIP traffic (which includes receiving the voice from the other end of the "call") a more open (unrestricted) path to your VoIP adapter.

Of course, this isn't a "cure all", and sometimes even this won't be enough to get fully working voice. But in many cases, the router on your LAN is the culprit that is causing the problems (by blocking the inbound VoIP packets needed for the call). And often the better the router's "firewall", the more likely the router is to cause problems in this respect (so higher end routers can actually be WORSE in this regard). But if you explicitly "port forward" the VoIP traffic (to your VoIP adapter), the problem often goes away. Because you have then told the router to always accept that traffic (and always send it to your VoIP adapter), even if/when the router thinks it came in "unsolicited" from the internet.
DracoFelis is offline   Reply With Quote
The Following 3 Users Say Thank You to DracoFelis For This Useful Post:
emoci (09-26-2007), kurun (09-16-2007), lamo (09-17-2007)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
Voxalot and Sipura/ATA Tutorial: A Comprehensive Walkthrough ctylor Voxalot General 5 04-28-2010 12:52 AM
Incoming calls do not function in Voxalot Premiun pauloneopark Voxalot Support 18 08-09-2007 01:20 PM
Provider Registrations and Call Forwarding - is VoXaLot support really needed? v164 Voxalot Support 2 07-07-2007 05:25 AM
Trying to get incoming calls to ring via Sipgate number. ukguy Voxalot Support 5 12-28-2006 02:16 PM


All times are GMT. The time now is 04:50 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.