Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 05-17-2007, 08:15 PM   #1
pironato
Junior Member
 
Join Date: Jan 2007
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
pironato is on a distinguished road
Default Incoming call problem

Hello,
I have a problem with incoming calls.
I have 3 VOIP accounts: 2 for incoming calls (one in Italy and one in Finland) and one for outgoing call.
Then the problem happen pretty often with incoming call: when i get the line i don't hear nothing; same in the other side they don't hear nothing as well.
This problem happen with both providers.
This doesn't happen with outgoing calls.
My Voxalot account is registered in a Grandstream budge tone 100.

Do you have some idea, suggestion to resolve this problem?

Thanks!
pironato is offline   Reply With Quote
Unread 05-18-2007, 08:54 AM   #2
tomblandford
Senior Member
 
Join Date: Jan 2007
Posts: 222
Thanks: 44
Thanked 23 Times in 22 Posts
tomblandford is on a distinguished road
Send a message via Skype™ to tomblandford
Default

Could be a firewall problem. Do you have NAT enabled on your ATA?
tomblandford is offline   Reply With Quote
The Following User Says Thank You to tomblandford For This Useful Post:
martin (05-18-2007)
Unread 05-18-2007, 12:22 PM   #3
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

Can you have good 2 way conversation to the Voxalot account?
Try calling your account from a landline using a SIP-Broker access number.
Also, have you tried calling test numbers (Eg. *600)?
If you DMZ the phone, there should be no firewall issues.

Do you have more than 1 SIP device or softphone running behind the same firewall?

Last edited by kurun; 05-18-2007 at 12:23 PM. Reason: Typo's
kurun is offline   Reply With Quote
The Following User Says Thank You to kurun For This Useful Post:
martin (05-18-2007)
Unread 05-18-2007, 08:20 PM   #4
pironato
Junior Member
 
Join Date: Jan 2007
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
pironato is on a distinguished road
Default

If it is a firewall problem can it be that some time works and some time doesn't work?
I checked out my phone setting(grandstream budge tone 100) and i can see only 2 parameters related to nat (as far as I can understand):
NAT Traversal: No
Use NAT IP: empty

I tried 2 way conversation to the voxalot account and it worked ok:
with *600 i was able to hear my voice repeated back with a very good latency.
i tried a SIP-broken access number as well and it worked just fine.

thanks guys!
pironato is offline   Reply With Quote
Unread 05-19-2007, 02:38 PM   #5
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

If you have more than one SIP device active at the same time, I found it works far more reliably if the SIP Port is incremented for every SIP channel (5060, 5061, 5062, 5063, etc).

I currently have a GXP2000, HT496, and a BT102 running reliably behind the same router. I was losing the registration on the ATA (HT496) before I did this change, and incoming calls would ring on the GXP2000, but not on the ATA registered to the same Voxalot account.

Calling from the ATA to the GXP phone, or vice-versa, would result in one way or no conversation most times.

Specifying a STUN server also seemed to help make the set-up work reliably.

For the GS BT-10x, I suggest the following:

NAT Traversal - Yes
STUN Server is - stun.voxalot.com.au:3478
Keep Alive Interval - 20 sec.
Use NAT IP: empty (Not sure what this does)
Register Expiration: Set to between 2 - 5 minutes (Seems to work better, and I hope it does not cause any problems for the Voxalot servers)

[Added - By the way, does your BT100 have the latest firmware from the GS website?]

Once you establish that the Voxalot account is working reliably with your IP-Phone, then you can focus on the problems with the incoming calls from the registered accounts (Italy and Finland numbers).

If you can do a simple forward from these accounts to xxxxxx@voxalot.com, your incoming will work far more reliably, as there will be no registration issues between Voxalot and the other VSPs. Unfortunately, many VSPs do not allow this, in which case a registration in the Voxalot account is required.

_.

Last edited by kurun; 05-19-2007 at 03:03 PM.
kurun is offline   Reply With Quote
The Following 2 Users Say Thank You to kurun For This Useful Post:
ctylor (05-20-2007), martin (05-25-2007)
Unread 05-19-2007, 09:08 PM   #6
pironato
Junior Member
 
Join Date: Jan 2007
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
pironato is on a distinguished road
Default

Thanks Kurun for the support.
I forgot to tell you that i have only one sip device, sorry.

I setup my bt100 as you suggested and i'll check next days the situation.

I don't have the clue to understand what you said:
"If you can do a simple forward from these accounts to xxxxxx@voxalot.com, your incoming will work far more reliably, as there will be no registration issues between Voxalot and the other VSPs"

my accout is 637400
pironato is offline   Reply With Quote
Unread 05-25-2007, 05:01 AM   #7
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

If you use a provider registered in the Voxalot provider list of your account, for incoming calls, the Voxalot server has to maintain a connection with your VSP to be able to receive the calls. If the registration is lost for any reason (happens sometimes!!), then you miss your call.

When a call is forwarded, no active connection is required between Voxalot and your provider. Your provider will simply "redirect" the call to 637400@voxalot.com.

Not all providers allow or support free forwarding to a SIP URL (637400@voxalot.com).

Some only allow forwarding to a PSTN number and charge for it. Others simply do not support the feature.

Hope this helps ............


For much more detail, see the following link :
http://forum.voxalot.com/voxalot-gen...lkthrough.html


_.

Last edited by kurun; 05-25-2007 at 05:03 AM.
kurun is offline   Reply With Quote
The Following 3 Users Say Thank You to kurun For This Useful Post:
martin (05-25-2007), pironato (05-25-2007), ronison (05-28-2007)
Unread 05-28-2007, 07:27 PM   #8
filmnet
Junior Member
 
Join Date: Sep 2006
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
filmnet is on a distinguished road
Default

Quote:
Originally Posted by kurun View Post
Tried all the settings as listed on that tutorial, but same problem:

1: No incoming calls (the caller just gets a 'number unobtainable' tone after a few seconds).
2: Outgoing calls work but cut off after several minutes.

I am using a Speedtouch 546 v6 router/modem as supplied by my ISP and a Sipura 1001 ATA.

I have a Virtualphoneline DDI number which goes to my Voxalot account, and my ATA is successfully registered to Voxalot.

Any ideas or suggestions guys?

-regards
filmnet
filmnet is offline   Reply With Quote
Unread 05-30-2007, 12:15 AM   #9
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

I have no experience with these devices.

Perhaps the first thing to try is to DMZ the IP address of the ATA. This should eliminate any NAT issues with the Sipura 1001.

Another possible avenue is to try to get the account working with an Xten softphone, which is fairly easy to set up, and well documented in the Tutorial section.

This would allow you to isolate the problem as to whether it is in the account set-up, dial-plan, etc, or whether it is device related or ISP related.
kurun is offline   Reply With Quote
The Following User Says Thank You to kurun For This Useful Post:
filmnet (05-31-2007)
Unread 05-31-2007, 07:26 PM   #10
filmnet
Junior Member
 
Join Date: Sep 2006
Posts: 19
Thanks: 1
Thanked 0 Times in 0 Posts
filmnet is on a distinguished road
Default

Quote:
Originally Posted by kurun View Post
Perhaps the first thing to try is to DMZ the IP address of the ATA. This should eliminate any NAT issues with the Sipura 1001.
Well I had a minor jubilation!

I tried calling my DDI after allowing all traffic to go to my ATA, and it worked!

Until I realised that my router hadn't saved the settings, and that it was a one-off fluke. I tried again and it didn't work :-(

Then I saved the settings and it still didn't work, and it stopped my access to the internet via my computer.

So I'm stuck again.

-filmnet

Edit: Tried disabling the firewall completely, but still no success. I am still trying to narrow down the problem...

Edit: Tried to do the port forwarding thing, no progress. But shouldn't STUN do it all for me? stun.xten.com is the server I plugged in there.

Edit: Well it must be a Sipura problem, as Express Talk takes incoming calls fine!

Last edited by filmnet; 05-31-2007 at 11:33 PM.
filmnet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mynetfone incoming call problem with voxalot acct sida168 Voxalot Support 0 05-19-2007 01:06 AM
Direct incoming calls SRV problem - alternative solution v164 SIP Broker Support 0 05-03-2007 02:01 AM
Call Forwading problem willy635 Voxalot Support 5 04-05-2007 04:37 AM
Stanaphone - problem incoming calls Jared Voxalot Support 3 01-29-2007 02:41 PM
My VoxAlot # never ring! (no incoming call) cgigate Voxalot Support 8 05-20-2006 05:15 AM


All times are GMT. The time now is 01:57 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.