Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 04-23-2006, 11:41 AM   #21
BJReplay
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
BJReplay is on a distinguished road
Question Well, it's working - more or less.

I put mynumber@voxalot.com in the voice mail server, while fiddling with a bunch of other settings, and after I hit sub all changes, dialled my own number, left myself a voice mail, hung up, and the little envelope appeared.

Woo Hoo.

Dialled 500, deleted the message, and after a short delay, the envelope dissappeared - well at least on some phones.

I have an InterQuartz IDea - and message waiting came up on the display at the same time as the other phones, but is still there - even though it has turned off on other phones and there are no voicemails waiting.

Now this is the wierd thing - I can manually force the message waiting indicator on on all phones by setting Message Waiting to Yes under Supplementary Service Settings on the User 1 tab. I can also set it off by - you guessed it - setting it to No. So that clears the "stuck" indicator on the IDea phone.

However, once a voice mail has been left, the indicator gets stuck on again.

I'm guessing - because the SPA can clearly turn the indicator on and off on both phones - that something in either my settings, or what Voxalot is sending - is causing it to stay stuck on (or more to the point, not clear the indicator when I clear the voice mail messages).

In the hope that someone can spot the problem, here are all my MWI / Voice Mail related settings (at least the ones I can see):

Line 1 Tab
Proxy and Registration Section
Voice Mail Server: mynumber@voxalot.com
Mailbox Subscribe Expires: 2147483647

Supplementary Service Subscription Section
VMWI Serv: Yes
MWI Serv: Yes

User 1 Tab
Supplementary Service Settings Section
Message Waiting: No

I think that Mailbox Subscribe Expires might be the problem? It appears that this is a 3.1.10 setting (I don't recall it in earlier firmwares), and 2^31-1 presumably means (almost) never. The only place I can see this mentioned is in the release notes for the Linksys SPA2100 - release 3.2.5(d). It says:

Added <Mailbox Subscribe Expires> paramter. Default is 0x7fffffff.

When Subscription to message-summary expires, SPA will
re-Subscribe to voicemail server. SPA will also honor the Expires
value returned by server if that value is less than the
configured expires value


This got me thinking that maybe voxalot isn't returning an Expires value in a message - making the SPA think that there is still a voice-mail waiting?

I can set this lower I guess, but I don't want to flood the voxalot server with meaningless voice mail registrations every 20 seconds, say, just to try this out - but I'm happy to if voxalot wants me to test this.

Of course I'd just try my settings with any other provider that offers voice mail with VWMI - but aside from MyTel, I don't think any of the free providers do.
BJReplay is offline   Reply With Quote
Unread 04-24-2006, 12:59 AM   #22
BJReplay
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 1
Thanked 0 Times in 0 Posts
BJReplay is on a distinguished road
Default

Quote:
Originally Posted by BJReplay
I can set this lower I guess, but I don't want to flood the voxalot server with meaningless voice mail registrations every 20 seconds, say, just to try this out - but I'm happy to if voxalot wants me to test this.
Quoting myself - I dropped this to 60 seconds, and it seems to have done the trick.

By the way, the other parameter that is related to VWMI that I didn't mention yesterday is VMWI Refresh Intvl - which is set to 0 (and apparently the default is 0.5). If I have this set above 0, my Doro DECT phones seem to spend 5 seconds every refresh interval thinking about the VWMI FSK that has presumably been sent down the line, and are never in a position to make or answer a call.
BJReplay is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vmwi in X-lite softphone 340742 Voxalot Support 3 03-01-2007 12:23 AM


All times are GMT. The time now is 06:15 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.