Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 07-25-2009, 09:44 PM   #11
All4Fun
Junior Member
 
Join Date: Jul 2009
Posts: 22
Thanks: 6
Thanked 3 Times in 2 Posts
All4Fun is on a distinguished road
Default

Quote:
Originally Posted by boatman View Post
That is a good dial plan, and yet your PAP2 doesn't allow use of the speed dial memories. If 'Interdigit Long Timer' and 'Interdigit Short Timer' are at factory defaults, 10 and 3 respectively, then I can only assume that your PAP2 is faulty.

Other than my test number, can you call Voxalot numbers without difficulty?
Any number I have dialed has gone through without difficulty The interdigit settings are at the default 10 and 3.

Remember that I have 2 ATAs experiencing the same issue so I'm thinking it would be highly unlikely that I would have 2 defective ATAs that weren't purchased at the same time.

Will keep diggin'...I wouldn't suspect my issue to be so unique after all.

Thanks for your time on this.
All4Fun is offline   Reply With Quote
Unread 07-25-2009, 10:24 PM   #12
All4Fun
Junior Member
 
Join Date: Jul 2009
Posts: 22
Thanks: 6
Thanked 3 Times in 2 Posts
All4Fun is on a distinguished road
Default

Found out my problem with dialing "2#". I had to enable "IP Dialing".

With that out of the way, I made the call and got "You're behind a SIP Compatible router, you are ready to make...."

So, some small progress anyway. Hopefully, this will help things along.
All4Fun is offline   Reply With Quote
Unread 07-25-2009, 10:28 PM   #13
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

The test call to *0@proxy01.sipphone.com:5060 should work if you set 'Enable IP Dialing:' = yes. I initially overlooked that necessity because I routinely run with 'Enable IP Dialing' set to yes.
boatman is offline   Reply With Quote
Unread 07-25-2009, 10:32 PM   #14
All4Fun
Junior Member
 
Join Date: Jul 2009
Posts: 22
Thanks: 6
Thanked 3 Times in 2 Posts
All4Fun is on a distinguished road
Default

Quote:
Originally Posted by boatman View Post
The test call to *0@proxy01.sipphone.com:5060 should work if you set 'Enable IP Dialing:' = yes. I initially overlooked that necessity because I routinely run with 'Enable IP Dialing' set to yes.
It'll be part of my routine too going forward.

What's the syntax for dialing the earlier Voxalot number because that still fails? If it's no longer necessary, just let me know.
All4Fun is offline   Reply With Quote
Unread 07-25-2009, 10:43 PM   #15
All4Fun
Junior Member
 
Join Date: Jul 2009
Posts: 22
Thanks: 6
Thanked 3 Times in 2 Posts
All4Fun is on a distinguished road
Default

I'm seeing this message quite a bit in my router logs:

[INFO] Sat Jul 25 18:40:37 2009 SIP ALG rejected packet from 64.34.173.199:5060 to 99.228.113.xx:5060 (I hid the last octet)

Don't know what it means but doesn't seem to be good.
All4Fun is offline   Reply With Quote
Unread 07-25-2009, 11:46 PM   #16
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Quote:
Originally Posted by All4Fun View Post
What's the syntax for dialing the earlier Voxalot number because that still fails? If it's no longer necessary, just let me know.
Just like dialing any normal Voxalot number; 6-digits then press # or wait for the interdigit timeout.

Quote:
Originally Posted by All4Fun View Post
[INFO] Sat Jul 25 18:40:37 2009 SIP ALG rejected packet from 64.34.173.199:5060 to 99.228.113.xx:5060 (I hid the last octet)
64.34.173.199 is us.voxalot.com also known as proxy02.us1.voxalot.com. I guess 99.228.113.xx is your home IP address.

Why is port 5060 shown in the log? Aren't you accessing Voxalot on port 4060 using VoXalot Specific Settings (when using ports 80, 443, 2060, 3060, 4060)? Looks like your router may be dropping SIP packets due to SPI or perhaps another security feature.
boatman is offline   Reply With Quote
Unread 07-26-2009, 11:38 AM   #17
All4Fun
Junior Member
 
Join Date: Jul 2009
Posts: 22
Thanks: 6
Thanked 3 Times in 2 Posts
All4Fun is on a distinguished road
Default

I've reduced the complexity in my environment by simply working with 1 ATA now. Line 1 is configured to register with voip.ms which works fine. Line 2 is configured for VoXalot on port 4060 and where I'm having incoming audio issues as described earlier.

I no longer have errors in my log.

Admittedly, I'm getting frustrated. We're both spending more time on this than should be necessary but I remain hopeful.

And yes, 99.228.113.xx is my home IP address.
All4Fun is offline   Reply With Quote
Unread 07-26-2009, 05:34 PM   #18
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Depending on which Wiki settings you used your ATA's NAT settings may need to be changed. Set the following:

set the following:

(under SIP tab)
Handle_VIA_received: yes
Handle_VIA_rport: yes
Insert_VIA_received: yes
Insert_VIA_rport: yes
Substitute_VIA_Addr: yes
Send_Resp_To_Src_Port: yes
STUN_Enable: yes
STUN_Test_Enable: yes
STUN_Server: stun.voxalot.com:3478 (or any STUN server such as 'stun01.sipphone.com:3478' or 'stun.sipgate.net:10000')
NAT_Keep_Alive_Intvl: 179

(under Line_1 and Line_2 (or PSTN_Line) tabs)
NAT_Mapping_Enable: yes
NAT_Keep_Alive_Enable: yes
NAT_Keep_Alive_Msg: (this setting should be blank)
NAT_Keep_Alive_Dest: $PROXY
Register Expires: 3600

In your Voxalot account set 'Symmetric NAT Handling' = Yes. This will have an effect only if Voxalot sees that your ATA has disabled NAT mapping. Your ATA will disable NAT mapping only when STUN_Test_Enable = yes and the ATA is behind a behind a symmetric NAT router. I hope this combination of settings will give optimum performance in any environment.

Sometimes SPI or other security features in the router must be disabled in order for SIP packets to pass. Experiment with disabling router security settings only if necessary.

Over at voip.ms you should probably set NAT = no. Regarding 'Device type' Voxalot is a 'IP PBX Server or Softswitch'. I don't know if that setting matters, you can experiment with it. Unfortunately voip.ms doesn't say what changes they make in response to the various settings they offer.
boatman is offline   Reply With Quote
Unread 07-26-2009, 06:24 PM   #19
All4Fun
Junior Member
 
Join Date: Jul 2009
Posts: 22
Thanks: 6
Thanked 3 Times in 2 Posts
All4Fun is on a distinguished road
Default

I made all the suggested changes above except I did not make any changes to line 1 as it's working fine directly connected to voip.ms.

I set NAT=no at voip.ms and it didn't make a difference.

As a test, I configured my router to put my ATA on the DMZ. Surprisingly, that didn't work either and still only get audio one way.

My thinking is that if the ATA can't even work on the DMZ with no firewall filtering, then I have config issues on the ATA itself and *maybe* voip.ms. Mind you, connecting directly to voip.ms on line 1 works fine.

I've documented all of my changes and nothing is working.
All4Fun is offline   Reply With Quote
Unread 07-26-2009, 06:42 PM   #20
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Try pointing your voip.ms SIP URI forwarding to your number at voxalot.com, not us.voxalot.com, 123456@voxalot.com, not 123456@us.voxalot.com.

I don't have a DID at my voip.ms account, but if there's a way I can test forwarding from voip.ms to my Voxalot account, let me know and I'll give it a try.
boatman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
incoming sip calls going directly to voicemail vishal3110 Voxalot Support 8 12-13-2008 12:17 AM
Some incoming SIP URI dialed calls slient Tylo Voxalot Support 9 04-09-2008 05:24 PM
All incoming calls failing richard Voxalot Support 1 09-15-2007 05:42 PM
Nor receiving incoming calls Sharps1 Voxalot Support 1 10-16-2006 12:38 PM


All times are GMT. The time now is 12:19 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.