Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > SIP Broker Forums > SIP Broker Support

SIP Broker Support Support for the SIP Broker service.

 
 
Reply
Thread Tools Display Modes
Unread 05-21-2009, 05:34 PM   #1
avoipuser
Junior Member
 
Join Date: May 2009
Location: U.K.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
avoipuser is on a distinguished road
Default Any Linksys / Sipura dial plan experts here

Are there any Linksys / Sipura dial plan experts here ?

The part of my existing dial plan to handle SIP broker calls is:

|*x.<:@sipbroker.com>|

so that any number starting with * is passed to SIP broker.

If I dial, for example

*258 nnnnnnnn #

where nnnnnnnn is a 8 digit VOIPtalk user number, it connects to that VOIPtalk user OK.

However if I forget to dial the # and only dial

*258 nnnnnnnn

I end up dialling a Mozambique number (the VOIP service I am logged into accepts * as the international dialling prefix and 258 is the country code for Mozambique).

I can't include the S0 terminator in the dial plan because SIP broker calls have varying lengths.

Does anyone know a way of not requiring the # terminator to be dialled ?

The Linksys software version I am using is 3.1.22(LS)

I have tried reading Answer
but this does not appear to offer a way of doing this.

Last edited by avoipuser; 05-21-2009 at 10:03 PM.
avoipuser is offline   Reply With Quote
Unread 05-22-2009, 11:01 PM   #2
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by avoipuser View Post
Are there any Linksys / Sipura dial plan experts here ?

The part of my existing dial plan to handle SIP broker calls is:

|*x.<:@sipbroker.com>|

so that any number starting with * is passed to SIP broker.

If I dial, for example

*258 nnnnnnnn #

where nnnnnnnn is a 8 digit VOIPtalk user number, it connects to that VOIPtalk user OK.

However if I forget to dial the # and only dial

*258 nnnnnnnn

I end up dialling a Mozambique number (the VOIP service I am logged into accepts * as the international dialling prefix and 258 is the country code for Mozambique).

I can't include the S0 terminator in the dial plan because SIP broker calls have varying lengths.

Does anyone know a way of not requiring the # terminator to be dialled ?

The Linksys software version I am using is 3.1.22(LS)

I have tried reading Answer
but this does not appear to offer a way of doing this.
For the time being I would try this:
|<#:>*xxx[x*].<:@sipbroker.com>|

And dial all SipBroker destinations as #-*SipCode-Number (with or without # at the end)

or try
|<#:*>xxx[x*].<:@sipbroker.com>|

and you can dial #-SipCode-Number (instead of *SipCode-Number) (with or without # at the end).


Lastly, I am sure we can fix the currrent dialplan...but could you post the entire DialPlan including everything else you've got there...(dialing # at the end helps make calls go quicker...but it should not affect call routing)
emoci is offline   Reply With Quote
Unread 05-23-2009, 05:09 AM   #3
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Quote:
Originally Posted by avoipuser View Post
... I can't include the S0 terminator in the dial plan because SIP broker calls have varying lengths. Does anyone know a way of not requiring the # terminator to be dialled? ...
When a number is processed through a dial plan entry which allows for variable number of digits and specifies a proxy, that number will be sent to the server listed in the ATA's "Proxy:" setting of the line in use, unless the number is terminated with the # character. Therefore, if you have set one of Voxalot's proxies (such as us.voxalot.com) in "Proxy:" then you must terminate the number with # when you want the call routed through a different server specified in the dial plan.

I suggest you use S60 in the dial plan (or begin the entire dial plan with L:60,S:60,) in order to delay the call for 60 seconds when you forget to press #.

If you are using the DNS SRV option (for server failover) then you must specify a port number with any proxies in the dial plan. This is done to prevent the ATA from trying to route calls to (for example) the non-existent _sip._udp.sipbroker.com instead of sipbroker.com. Your sipbroker dial plan entry would be |*x.<:@sipbroker.com:5060>|

Last edited by boatman; 05-23-2009 at 05:39 AM.
boatman is offline   Reply With Quote
The Following User Says Thank You to boatman For This Useful Post:
emoci (05-23-2009)
Unread 05-24-2009, 03:39 PM   #4
avoipuser
Junior Member
 
Join Date: May 2009
Location: U.K.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
avoipuser is on a distinguished road
Default

Thanks everybody for the suggestions.

I ended up using that tip of setting very long inter-digit long and short timers to force having to terminate the number with a #. I figured this was a small inconvenience to ensure I didn't get any more unexpected foreign call charges to obscure countries.

I chose very large numbers:

L:9999,S:9999,

as I though that would make their use a bit more obvious.

In my search for an answer I also found out about the little documented P (pause) syntax for dial plans. It's mentioned near the end of that Cisco knowledge base article.

I won't post my full dial plan (it's now about 470 characters long), an entry like:

|<:00998888>[2-9]xxxxxP3|

still allows my local (6 digit) numbers to auto complete if no new digits are dialled for 3 seconds even with the very large short inter-digit timer setting. (I've substituted 998888 in place of my actual country and city code).

Last edited by avoipuser; 05-24-2009 at 03:47 PM.
avoipuser is offline   Reply With Quote
Unread 06-17-2009, 02:35 PM   #5
tararumpum
Banned
 
Join Date: Jan 2009
Posts: 8
Thanks: 3
Thanked 1 Time in 1 Post
tararumpum is on a distinguished road
Default

Quote:
Originally Posted by boatman View Post
|*x.<:@sipbroker.com:5060>|
Hi,
I am quite new to the voip. I was looking for a dial plan to use sipbroker and i must say the above dial plan (without "#" ) worked a treat, perfect. It doesn't show me mozabique country either ;-)
tararumpum is offline   Reply With Quote
Unread 06-24-2009, 09:24 AM   #6
DracoFelis
 
DracoFelis's Avatar
 
Join Date: Mar 2006
Posts: 188
Thanks: 4
Thanked 64 Times in 41 Posts
DracoFelis is a jewel in the roughDracoFelis is a jewel in the rough
Default

Quote:
Originally Posted by tararumpum View Post
Hi,
I am quite new to the voip. I was looking for a dial plan to use sipbroker and i must say the above dial plan (without "#" ) worked a treat, perfect. It doesn't show me mozabique country either ;-)
One minor thing I would change (although it likely won't help with the need to end with the #-key) is to use instead:

| *xxx[x*]. <:@sipbroker.com> |

The reason this is somewhat better, is that it doesn't send all calls that start with an *-key to SIP Broker, but rather only calls that start with an *-key and 3+ digits (which includes all the valid SIP Broker dialing strings).

By adding this additional tweak, you get the benefit of some *-codes not being (incorrectly) seen as SIP Broker dialing. For example, *69 (call back) could be (incorrectly) treated as SIP Broker dialing with the initial dial plan, but will (correctly) not be seen as SIP Broker dialing with the more specific dial plan piece.
DracoFelis is offline   Reply With Quote
The Following User Says Thank You to DracoFelis For This Useful Post:
tararumpum (06-24-2009)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Voxalot and Sipura/ATA Tutorial: A Comprehensive Walkthrough ctylor Voxalot General 5 04-28-2010 12:52 AM
Dial plan and various problems 800793 Voxalot Support 6 11-19-2007 01:05 PM
Dial plan problems with FaktorTel and VoXaLoT Hally Voxalot Support 1 01-06-2007 09:21 AM
Norway toll free number dial plan ? shezad Voxalot Support 1 11-11-2006 12:09 AM
dial plan help please muzzza Voxalot Support 0 09-01-2006 11:38 AM


All times are GMT. The time now is 07:37 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.