Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 05-15-2009, 02:54 PM   #1
505117
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
505117 is on a distinguished road
Thumbs down Voice Service Provider registration problem. Help!

I have a problem with provider registation. The registration status is "Registered" at "Voice Service Provider List" but this is not the actual situation. I called the customer assistance of my VSP and they said me my account was not registered that moment. So, for Voxalot it was registered when in fact it was not. I tried to reset the registration changing the option "SIP Register" to "No", but the system continued to show the wrong status "Registered". Finally, I bypassed Voxalot reconfiguring my ATA to register directly with the provider and the registration worked without problems.

Please check! Incoming calls from provider are not working!

BTW, I would like to suggest the implementation of a way to reset the registration, something like a button to "unregister" and then "re-register" with the provider.

Another suggetion is to give more information about registration process, like how much time ago was the last registration attempt, when is the next registration attempt, what was the response from the provider. These information could help troubleshooting registration problems.

Thanks.
Attached Images
File Type: jpg VSPList.JPG (13.7 KB, 12 views)
505117 is offline   Reply With Quote
Unread 05-15-2009, 09:13 PM   #2
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 368 Times in 281 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by 505117 View Post
I have a problem with provider registation. The registration status is "Registered" at "Voice Service Provider List" but this is not the actual situation. I called the customer assistance of my VSP and they said me my account was not registered that moment. So, for Voxalot it was registered when in fact it was not. I tried to reset the registration changing the option "SIP Register" to "No", but the system continued to show the wrong status "Registered". Finally, I bypassed Voxalot reconfiguring my ATA to register directly with the provider and the registration worked without problems.

Please check! Incoming calls from provider are not working!

BTW, I would like to suggest the implementation of a way to reset the registration, something like a button to "unregister" and then "re-register" with the provider.

Another suggetion is to give more information about registration process, like how much time ago was the last registration attempt, when is the next registration attempt, what was the response from the provider. These information could help troubleshooting registration problems.

Thanks.
Even though you turned off SIP Register...the status is not updated immediately...so it could take a few minutes before the 'Registered' line disappears...( even though the provider was actually de-registered).

If you really want to force a registration off...simply set it up with the incorrect password...which will cause it to fail and clear the registration immediately...

Now as for incoming calls not working when you're registered I'm concerned that this may be the case:

Vono may not be correctly accepting the register information (eg. http://forum.voxalot.com/voxalot-sup...html#post15138 )
emoci is offline   Reply With Quote
Unread 05-15-2009, 10:37 PM   #3
505117
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
505117 is on a distinguished road
Default

Hi emoci,

Thank you for the instruction about clearing the registration immediately, although this is a workaround.

Concerning incoming calls, I meant that because there was no registration with provider, consequently there was no incoming calls from this provider. So, it was not another problem but a consequence of the same problem. Anyway, now the registration is ok and incoming calls are working.

The point that I would like to emphasize is the fact that the registration with the provider was finished without any reason and the status continued "Registered". This wrong information confuse me in what to do to solve the problem. Hopefully the registration will not fail anymore.

Thanks.
505117 is offline   Reply With Quote
Unread 05-16-2009, 12:52 PM   #4
505117
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
505117 is on a distinguished road
Default Registration fail again

Hi emoci,

The same problem occurred again. The registration with the provider stopped, but at Voxalot the status was "Registered". Without registration with provider, incoming calls stopped also.

Please, could you check why the registration is failing?

Thanks.
505117 is offline   Reply With Quote
Unread 05-16-2009, 05:08 PM   #5
carlosalbffgomes
Senior Member
 
Join Date: May 2008
Location: Portugal and Brazil
Posts: 107
Thanks: 7
Thanked 26 Times in 21 Posts
carlosalbffgomes is on a distinguished road
Default Vono Registration

I'm also using Vono and sometimes it looses registration. I've tried it with US and EU Voxalot servers, both with issues. I have some hypothesis about what can be going on, but I don't know for sure. I tried also with 'Sym NAT' and 'Optimize Audio Path' options to 'yes' and to 'no'. For me it seems to work better with the Voxalot default configuration, that is, 'Sym NAT' to 'yes' and 'Optimize Audio Path' to 'no'.
Among what I think it may be happening there is the possibility that the registration expiration time with Vono is smaller than the re-registering time that Voxalot uses. Some providers defines maximum and minimum values to the re-registering time, ignoring the value sent to them in the registration dialogue if that value is greater or lesser than the default values.
Another possibility is among what 'Sym NAT' really does. In my experiments using the 'Sym NAT' option to 'no' it seams that an INVITE message is sent to my ATA and answered before VONO starts ringing. So, if my IP changes meanwhile (my ADSL connection have dynamic IP) the re-registration period occurs, my ATA will be out of reach and VONO sends the call to voicemail. I have to say that I really have much less issues when I use 'Sym NAT' to 'yes'.
Another possibility is Server unresponsiveness due to overload. That some times may occur and after it the VSP will think that ATA is offline until next registration. Vono also seams to have some king of firewall defence strategy. If I register my account from my ATA after registering at Voxalot it doesn't ring in either places (despite being registered!) and the call goes to voicemail.
Only one last word: Vono support is not that good. In last April there was a general fault with VISA/MASTERCARD and they didn't understood what happened, starting saying that the problem was with the person's card operator. I was one who had such problems (others had it also as is being told on Vono forums) and they didn't do a thing about it despite all contacts I've estabished with my bank and card operator, which have told me that the authorization request from VONO didn't reach them. I told it one and more times to Vono support with no luck. One and a half month latter it seams to be working again. So, Vono support is not worse than what we have here where I'm living for the time being, but it is not that good as it should be. So, do not believe in everything you are told: it simply may not be the truth.
Regards,
carlosalbffgomes is offline   Reply With Quote
Unread 05-18-2009, 07:21 PM   #6
505117
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
505117 is on a distinguished road
Default Registration status certainness

I agree that there could be several possibilities for this problem, although in my opinion this problem it is not related with "Symmetric Nat" option and/or "Optimize Audio Path" option. I also agree that the provider customer assistance is not a "dream team", but in this specific case I believe that they gave me the right information, as long as it was only about the registration status (yes or not). On the other hand, an issue with the timers configuration is more likely. Server unresponsiveness is another possibility.

In the end, the point is that all possibilities are in the field of uncertainty because from ATA onwards everything is a cloud and there is no visibility for the users about what really happens between Voxalot and the provider. I believe this could improve if there were more information and certainness about provider registration status.

I also read the case http://forum.voxalot.com/voxalot-sup...html#post15138 but the problem is not the same, because I did not receive any error message, instead the calls were diverted directly to the provider voice-mail (not Voxalot voice-mail) because of registration loss.

Thanks!
505117 is offline   Reply With Quote
Unread 05-20-2009, 08:19 PM   #7
505117
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
505117 is on a distinguished road
Angry Registration loss again!

The registration with provider is down again.

I ask someone in Voxalot Staff to help solve this problem. It was not my expectation when I bought this service to have this type of problem.

Please help!
505117 is offline   Reply With Quote
Unread 05-21-2009, 09:45 AM   #8
carlosalbffgomes
Senior Member
 
Join Date: May 2008
Location: Portugal and Brazil
Posts: 107
Thanks: 7
Thanked 26 Times in 21 Posts
carlosalbffgomes is on a distinguished road
Default

As far as I can tell you, I'm not having such registration problems with Vono. If different from what you are using, you can try something like this (this is my configuration settings):

1. Voxalot Server: EU (the other week there was a general fault with US servers: all VSPs lost their registration);
2. ATA with DNS SRV active;
3. Vono Configuration: vono.net.br:1571 (not the standard 5060 IP port);
4. Sym NAT: YES;
5. Optimize Audio Path: NO (choosing 'yes' with 'Sym NAT' to 'no' will make you loose audio after some time; at least I had that issue when I tested it).

Vono has been working good for me, despite some registration issues at the past. However, from some time until now I've not reported any such problems. And the above configuration is for me the one that works best. I don't think that matters, but I've also said in one of my contacts with Vono's SAC (0800 6008666) that I was using Vono through ATA and not with the softphone.
Regards,

Last edited by carlosalbffgomes; 05-21-2009 at 01:03 PM.
carlosalbffgomes is offline   Reply With Quote
Unread 05-21-2009, 01:31 PM   #9
505117
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
505117 is on a distinguished road
Exclamation Not so simple.

Olá Carlos,

Thank you for sharing your configuration. My configuration is almost the same, except the "SYM Nat" and "Optmize Audio Path" option set to No and Yes, respectively. The problem is that configuration penalize the audio quality increasing significantly the delay. Considering that you are in Europe and your ATA registered in EU Voxalot server, when you call someone in Brazil the audio path is almost the same with "Optmize Audio Path" option with either Yes or No. On the other hand, for me is not that simple, because I am in Brazil and the audio would have a long trip even if I call my neighbor. So, this configuration is not good for me.

I have tried registering other provider like Voxalot with Vono, with a similar configuration (without that provider proxying the audio) and the registration is stable. Even when I register from my ATA directly to Vono the registration is stable and no uncommon configuration is needed.

Other issues are:
- Provider registration status with no reliable information
- No tools to reset registration easily (only workaround)
- No additional information about registration status (timers, last response from provider)
- No option to forward calls in case of registration failure

I would like to ask Voxalot Staff for help and I am willing to work together to solve this problem.

Regards.

André
505117 is offline   Reply With Quote
Unread 05-21-2009, 02:18 PM   #10
carlosalbffgomes
Senior Member
 
Join Date: May 2008
Location: Portugal and Brazil
Posts: 107
Thanks: 7
Thanked 26 Times in 21 Posts
carlosalbffgomes is on a distinguished road
Default Give it a try

Oi André

As far as RTP proxy is concern, the about 200 ms overhead introduced by using it doesn't deteriorate considerably the audio quality. I have already used both configurations with EU and US servers and it's almost unnoticeable. For example, the RTP delay introduced by some VSP (for example, BlasterPhone and VoipBuster) are bigger than what we are talking about. And, I must say from what I've tested so far, Vono wouldn't work with 'Audio Optimization Path' setted to 'yes' (when I tried it and someone called me from Brazil, I loosed the audio about 10 minutes after the call initialization) and maybe 'Sym NAT' may work in your case. Understanding the SIP dialogues that take place in call's initialization, it may make all the difference because it means that, if you have 'Sym NAT' set to 'no', the SIP registration and the station answering the call wouldn't be on the same IP address. That is sufficient, some times, to make trouble with some routers through which the connection would pass through. So, at least to check if that works for you, I would give it a try.
Also I would like to use 'Optimization Audio Path' to 'yes', at least for some calls destinations. But this configuration was the best balanced I could get between reliability and call quality. There's no such thing as free lunch, so you must balance between variables to get the most you can.
Another option is to use another free service: mysipswitch (at My SIP Switch Use multiple VoIP providers with one SIP phone). This service only deals with SIP traffic, is free and works with Vono (I've already tried it). But it has no automatic backup as Voxalot have through SRV DNS.
Regards,
carlosalbffgomes is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
HowTo: 6 Steps To Tune Your Voice Quality martin Voxalot Tips, Tricks & HowTo's 13 12-27-2010 11:36 AM
Voxalot and Sipura/ATA Tutorial: A Comprehensive Walkthrough ctylor Voxalot General 5 04-28-2010 12:52 AM
Voice Service Provider problem sempaitken Voxalot Support 7 12-12-2007 12:54 AM
Voxalot does not release Registered Number once deleted from Voice Service Provider L xvaiox Voxalot Support 4 08-05-2007 09:55 AM


All times are GMT. The time now is 11:37 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.