Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 11-17-2007, 05:52 AM   #1
800793
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
800793 is on a distinguished road
Default Dial plan and various problems

Maybe someone is working with the server or the server is upgrading... I registered new accounts with Voxalot and in the past two days there were various problems. e.g. the echo test had no problem, however, only one party can hear the other, the other party cannot hear anything. Or the softphone got the message "waiting for acknowledgement" and eventually disconnects. And the dial plan sometimes does not work. I've noticed that problems occured when the call routed through dial plan, e.g. _xxxxxx through voxalot, or ${EXTEN:ReplaceAll}SomeID through SomeProvider. If I dial something directly like *010xxxxxx or SomeID@SomeProvider.com, there were no problems.

Now most of the problems disappeared, but there are still two problems remain. 1st, for any call through dial plan, the callee will get disconnected at about 30 seconds. 2nd, the dial plan cannot be changed. You can still change dial plans in your account from the web site, however, the changes are not actually committed to your account though the web site shows the new dial plan. Maybe someone working with the server found problems with dial plan and freezed account dial plan change, or maybe it is just my account that got problem. Spent too much time to figure it out.
800793 is offline   Reply With Quote
Unread 11-17-2007, 10:29 AM   #2
800793
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
800793 is on a distinguished road
Default

Some progress. I switched back to sjphone, and the "awaiting acknowledgement" problem appeared again. So it's actually the the same problem as the 30 seconds connection problem. It's only that shphone reports this problem, but eyebeam does not report this problem however eyebeam will also disconnect in 30 seconds.

To restate it, any call that goes through the dial plan will have the above problem.

I've tried the method as mentioned by Martin in previous post to uncheck the "use disconvered address in SIP". It does not seem to work. I have account with PBXes and it worked fine with softphones without any tweak. I've tried various settings with softphones and my Voxalot account, none will work. Maybe the only way out is to set port forwarding.

The dial plan change still works, only seems slow to commit from the web change to actual account change. It was taking effect on the fly one or two days ago when I made changes on the web.
800793 is offline   Reply With Quote
Unread 11-17-2007, 10:36 AM   #3
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Hi,

You have "Symmetric NAT Handling" set to "No". Set this to "Yes" and try unchecking the "use discovered address in SIP" setting in SJPhone.

The dial plan updates were an issue today due to the web server upgrade. This should no longer be a problem.

Thanks
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
Unread 11-17-2007, 11:02 AM   #4
800793
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
800793 is on a distinguished road
Default

It's the same. I've tried all the combinations of settings I can think of. The audio was transmitted and received fine on both party in the first 30 seconds though the sjphone reports "awaiting acknowledgement". I remembered long time ago when I got the same message with sjphone with some VSP account, the call was not connected at the time "awaiting acknowledgement". Now that the call is actually connected in the 30 seconds, and the problem only occurs when the call is routed through the dial plan, it looks like there is a small bug in the dial plan routing.
800793 is offline   Reply With Quote
Unread 11-17-2007, 11:14 AM   #5
800793
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
800793 is on a distinguished road
Default

Looks like other people having the same problem didn't get a definite solution either. BTW, is "#" allowed in the dial plan string? I have some dial plans _#1x., _#2x. to choose among VSPs but got the message "the number could not be connected".
800793 is offline   Reply With Quote
Unread 11-19-2007, 07:16 AM   #6
800793
Junior Member
 
Join Date: Nov 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
800793 is on a distinguished road
Default

So far, spa1001 has been tested to work behind router without port forwarding with no problem. So should be other spa or linksys products. SJphone, eyeBeam and ATS 6011s only work for 30 seconds for any call that routes through the dial plan. ATS 6011s needs Symmetric NAT Handling in order to register.
800793 is offline   Reply With Quote
Unread 11-19-2007, 01:05 PM   #7
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

"#" is usually programmed as a "Send" command in the ATA or IP phone.
So it is better to avoid using it in the dial plan string.
The ATA will never pass the character to the Voxalot server, if it uses it as an "End of Entry" and "Send" command.
kurun is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:20 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.