Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 05-19-2008, 06:36 PM   #1
Grahame
Member
 
Join Date: Aug 2006
Location: France
Posts: 46
Thanks: 2
Thanked 6 Times in 5 Posts
Grahame is on a distinguished road
Default All calls being sent to Voicemail

Having received several instances of people not being able to call me (straight to Voxmail ), I have called in to all my DID's with Providers registered in Voxalot and indeed all calls are going straight to Voicemail.

I have turned off Voicemail and I get nothing but silence.

I have removed all Call Forwarding, all calls to Voicemail.

I set Call Forwarding for all calls to my Voxalot account, all calls to Voicemail.

Can someone please explain what is going on. I have made no changes to my Voxalot or ATA settings. The ATA is on register to Voxalot

Best regards

Grahame
Grahame is offline   Reply With Quote
Unread 05-19-2008, 06:51 PM   #2
Grahame
Member
 
Join Date: Aug 2006
Location: France
Posts: 46
Thanks: 2
Thanked 6 Times in 5 Posts
Grahame is on a distinguished road
Default

I have just called my ATA on it's second port ( mysipswitch ) and everything works fine.

Voxalot issue ?

Best regards

Grahame
Grahame is offline   Reply With Quote
Unread 05-19-2008, 09:40 PM   #3
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

Can you check the status page on your ATA to see if both accounts are registering correctly?

Are you using the same SIP/RTP ports for both accounts? Suggest to use different ports (Eg 5060, 5062 / 5004, 5006)
You may be getting a conflict because of different expiration times between the two services.

Perhaps you can also try a different Voxalot server, or shut off the other account for debugging purposes.
kurun is offline   Reply With Quote
Unread 05-20-2008, 07:29 AM   #4
Grahame
Member
 
Join Date: Aug 2006
Location: France
Posts: 46
Thanks: 2
Thanked 6 Times in 5 Posts
Grahame is on a distinguished road
Default

Hi Kurun,

Thanks for your reply.

Both accounts are registered properly in the ATA.

Both accounts use different ports: 5060,5062

Expiry times are both set to 3600

I have tried running Voxlaot with the other account turned off, no difference.

I have moved all my principal DID providers to Mysipswitch ( Account 1 ) and all works fine. I have had to do this for testing but more importantly I need to receive calls. Voip supports my business and Voxlaot is my principal platform for this. I need these services running.

*600 and *500 work fine, it seems the Voxlaot server is not passing inbound calls to my ATA ( thinks it's busy, off line ?? ).

Could Martin or someone please have look at this from the Voxlaot end. There are several instances in my account i.e calls direct to Voicemail, which illustrate the problem.

Best regards

Grahame
Grahame is offline   Reply With Quote
Unread 05-20-2008, 04:44 PM   #5
ctylor
 
ctylor's Avatar
 
Join Date: Apr 2006
Location: Vancouver, BC
Posts: 296
Thanks: 94
Thanked 53 Times in 27 Posts
ctylor will become famous soon enough
Default

It still sounds like it might be a user-side problem. This same scenario happens for instance when your WAN side IP address changes prior to the registration expiry. Since your registration lasts 60 minutes, that means if your IP address tends to change more often than that, your incoming calls will all be in limbo, and go to VM or silence or cause a busy signal. I am not sure why your other provider would work while Voxalot didn't though, if you have the exact same settings across the board for both lines.

Try changing the expiration of the registration to 300 or 600 and see if that helps you.

Last edited by ctylor; 05-20-2008 at 04:47 PM.
ctylor is offline   Reply With Quote
Unread 05-20-2008, 06:14 PM   #6
Grahame
Member
 
Join Date: Aug 2006
Location: France
Posts: 46
Thanks: 2
Thanked 6 Times in 5 Posts
Grahame is on a distinguished road
Default

Hi ctaylor,

Thanks for your response.

There is certainly something weird going on. I took Provider A off register with Voxalot, registered A with Mysipswitch and asked A to call me. A reported the call went through correctly, but all they heard was music and the call then went off into the ether. Nothing my end.

I then took A off register with Mysipswitch, put A on register with Voxalot and asked A to make the call again. A said they heard music, the call went through, my phone rang but with one way audio i.e they could not hear me.

Provider A says they are sending the call correctly and the call is being received correctly. They do not provide music, they feel the music is being generated by an Asterisk source. Clearly they will not comment on what Mysipswitch or Voxalot do with the call once they they have handed it over.

All comments gratefully received.

I'm going to strip the whole system down tonight, close down Mysipswitch and put all back together in Voxalot with a single registration at 300 expiry.

Best regards

Grahame
Grahame is offline   Reply With Quote
Unread 05-21-2008, 03:47 AM   #7
kurun
 
Join Date: Sep 2006
Location: Toronto, Canada
Posts: 568
Thanks: 70
Thanked 147 Times in 115 Posts
kurun is a jewel in the roughkurun is a jewel in the rough
Default

My Voxalot registered ATA is set for SIP registration expiration of 120 seconds.
I have had issues with losing registration when setting for longer intervals, even though my IP address is stable.

One way audio usually indicates that there is an NAT issue.
Since the phone is ringing for incoming calls, the Registration server is obviously able to find yor ATA, but the RTP data is not transferring correctly.

What type of internet service do you have?
Are you using a router before the ATA?
If you are using a router, it would be advisable to use a STUN server also.
Are you using one VoIP device only or multiple VoIP devices on the same network?

I have seen situations where a correctly set-up ATA will not work properly when connected to a DSL modem directly, but will work perfectly with the same provider if connected behind a router.
I have not been able to understand why, and it is my suspicion that some providers only allow specific devices to connect to their network.
kurun is offline   Reply With Quote
Unread 05-21-2008, 05:13 AM   #8
ctylor
 
ctylor's Avatar
 
Join Date: Apr 2006
Location: Vancouver, BC
Posts: 296
Thanks: 94
Thanked 53 Times in 27 Posts
ctylor will become famous soon enough
Default

Heh.

Hard-reset the ATA, update the firmware if a newer version is available, and reprogram it from scratch. Then figure out what is still acting problematically.
ctylor is offline   Reply With Quote
Unread 05-22-2008, 05:30 PM   #9
Grahame
Member
 
Join Date: Aug 2006
Location: France
Posts: 46
Thanks: 2
Thanked 6 Times in 5 Posts
Grahame is on a distinguished road
Default

Hi guys,

Thanks again for your responses and my apologies for the delay in replying.

I now have a working system with Voxalot passing calls from my DID's with no problems. This has meant turning off one account in the ATA and removing one PC from my network. I am pretty sure the problem is either with the modem/router provided by my ISP or the ATA box itself.

The modem/router is a Livebox provided by Orange/France Telecom. This has a free VoIP service built into it, but Orange will not tell me settings or the technology being used. With two accounts active in the ATA and the free VoIP service running ( can't turn it off ! ), nothing works properly.

The ATA has an Ethernet pass through connection which avoids running cables i.e PC to ATA, ATA to Livebox ( it only has one Ethernet port ! ). With a PC connected to the pass through, irrespective of how many SIP accounts running, again nothing works as it should.

This is not the first problem I have had with Orange so come end of June I will be changing ISP ( and buying my own modem/router ! ). So unless anyone else out there is struggling with Orange in France, let's close this down.

I would however like your views on the ATA settings which are as follows:

Different SIP Local Ports for each account

Provider registration details as required

Expiration duration: 300
Register Re-send Timer:180
Session Expires:180
Min SE: 30

RTP Range: 3000 - 65535 ( This interests me as it's the same on both accounts, I can only set a range not a value, per account )

Nat Keep Alives:120

Stun configured on both accounts ( Voxalot and Xten )

Any thoughts on the above settings would be greatly appreciated.

Best regards

Grahame
Grahame is offline   Reply With Quote
Unread 05-22-2008, 11:28 PM   #10
ctylor
 
ctylor's Avatar
 
Join Date: Apr 2006
Location: Vancouver, BC
Posts: 296
Thanks: 94
Thanked 53 Times in 27 Posts
ctylor will become famous soon enough
Default

Quote:
Originally Posted by Grahame View Post
Expiration duration: 300
Register Re-send Timer:180
Session Expires:180
Min SE: 30

RTP Range: 3000 - 65535 ( This interests me as it's the same on both accounts, I can only set a range not a value, per account )

Nat Keep Alives:120
My guess for my equivalent since your terminology is different (mainly default settings [Sipura]):
Expiration duration: 600
Register Re-send Timer:30
Session Expires:7200
Min SE: 1

RTP Range: 16384-16482

Nat Keep Alives:28
ctylor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
incoming sip calls going directly to voicemail vishal3110 Voxalot Support 8 12-13-2008 12:17 AM
Incoming calls go straight to voicemail barristernet Voxalot Support 4 04-03-2008 08:18 AM
X-Lite and sending calls to voicemail jonfry Voxalot Support 1 04-11-2007 01:44 AM
No Voicemail On Incoming Calls Ron Voxalot Support 3 04-13-2006 01:54 PM


All times are GMT. The time now is 01:02 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.