Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 02-17-2009, 06:55 AM   #1
gsmlover
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 3
Thanked 0 Times in 0 Posts
gsmlover is on a distinguished road
Default WRTP54G / SPA2102 Incoming call - no sound

Hello Experts:

I'm facing a problem that many others have faced already and have spent several hours in making suggested changes on my side....but alas, with no success. My problem is - NO SOUND / VOICE on INCOMING calls...the phone rings but no voice is heard on either side. Outgoing is working Ok, except for some delay or sometimes I might have to hang-up and redial...but still managable.

I've tried - stun, port forward, NAT / Symmetric NAT, outbound proxy almost everything that I've read in the forum in last 48 hours, but the problem remains the same...and I've tested both WRTP54G router/ATA and SPA-2102 router/ATA.

I'm not a VOIP newbie (but surely not an expert by any means) as have been configuring ATAs for almost 2 years now for myself and my family, so I think I know a little bit what I'm doing as I've dealt with sipphone, callcentric, tpad previously on WRTP54G, SPA-2102, Dlink 1402S, RT31P2 etc. without any major hiccups like this one...because here nothing seems to work for me and desperately need some help! Also, importantly, for none of services like sipphone, tpad etc. I never had to use STUN or do port forwarding etc. as I'm using the router with built-in ATA, thus I'm of a view that this is already managed by these devices.

I'm sure experts/mod here, will definitely have fixed such issues previously.

Would really appreciate a help asap. Thanks in advance!
gsmlover is offline   Reply With Quote
Unread 02-17-2009, 08:58 AM   #2
carlosalbffgomes
Senior Member
 
Join Date: May 2008
Location: Portugal and Brazil
Posts: 107
Thanks: 7
Thanked 26 Times in 21 Posts
carlosalbffgomes is on a distinguished road
Default A modem/router issue?

Can it be a modem/router issue? I've seen your king of problems when using some ADSL modem/routers. If you have not already done, try to change the following: in Outbound Proxy write 'us.voxalot.com:80'. You can try with the following UDP ports where I have putted '80': 443, 2060, 3060, 4060. Depending on what hardware or software you are using you may need to change the UDP port for registration to the same value that you use for the Outbound Proxy (with a Linksys phone I have no need of it).
Usually, the one-way-audio or the no-sound problem are NAT issues. Really, some routers behave strangely.
Regards.
carlosalbffgomes is offline   Reply With Quote
The Following User Says Thank You to carlosalbffgomes For This Useful Post:
gsmlover (02-17-2009)
Unread 02-17-2009, 05:00 PM   #3
gsmlover
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 3
Thanked 0 Times in 0 Posts
gsmlover is on a distinguished road
Default No Sound On Incoming Call

Yes, right now - I'm playing with both type of modems cable as well as ADSL modem (at friends place)...but the result is the same.

Also, I'm using "us.voxalot.com:443" in Outbound Proxy already. And the "no sound on incoming call" problem remains the same on cable or ADSL modem or call coming from another voxalot account or through a sipbroker / sipphone.

Will really appreciate any further clues.
gsmlover is offline   Reply With Quote
Unread 02-17-2009, 06:10 PM   #4
kendid
Member
 
Join Date: Aug 2006
Location: UA
Posts: 72
Thanks: 6
Thanked 3 Times in 3 Posts
kendid is on a distinguished road
Default

I'm also no VOIP expert, but have fooled around a bit to get it working.

It sounds like you may have a NAT/Firewall Issue.

Try this --
Disable stun on your ATA
Enable Voxalot NAT Handling on your Member page

It worked for me, hopefully for you too...
kendid is offline   Reply With Quote
The Following User Says Thank You to kendid For This Useful Post:
gsmlover (02-17-2009)
Unread 02-17-2009, 06:18 PM   #5
gsmlover
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 3
Thanked 0 Times in 0 Posts
gsmlover is on a distinguished road
Default

Thanks Kandid - I did read your recommendation in the other post before and tried that option too...but still the same problem.
gsmlover is offline   Reply With Quote
Unread 02-17-2009, 07:09 PM   #6
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Quote:
Originally Posted by gsmlover View Post
...but still the same problem.
Is your SPA2102 behind NAT or does it have a public IP address? Normally you don't need or want Voxalot NAT Handling because that add latency (it proxies all your RTP packets).

I suggest you try the following settings. If that doesn't solve the problem, send me your Voxalot number and I'll give you a test call and have a look at some SIP packets.

======================

If your SIP device is on a public IP address, set as follows:

(under SIP tab)
Handle_VIA_received: no
Handle_VIA_rport: no
Insert_VIA_received: yes
Insert_VIA_rport: yes
Substitute_VIA_Addr: no
Send_Resp_To_Src_Port: yes
STUN_Enable: no
STUN_Test_Enable: no
STUN_Server: (does not matter)
EXT_IP: (does not matter)
NAT_Keep_Alive_Intvl: (does not matter)

(under Line_1 and Line_2 (or PSTN_Line) tabs)
NAT_Mapping_Enable: no
NAT_Keep_Alive_Enable: no
NAT_Keep_Alive_Msg: (does not matter)
NAT_Keep_Alive_Dest: (does not matter)
Register Expires: 3600
-------------------------------------------------

If your SIP device is behind one or more NAT routers, set the following:

(under SIP tab)
Handle_VIA_received: yes
Handle_VIA_rport: yes
Insert_VIA_received: yes
Insert_VIA_rport: yes
Substitute_VIA_Addr: yes
Send_Resp_To_Src_Port: yes
STUN_Enable: yes
STUN_Test_Enable: yes
STUN_Server: stun.voxalot.com.au:3478 (or any STUN server such as 'stun01.sipphone.com:3478' or 'stun.sipgate.net:10000')
NAT_Keep_Alive_Intvl: 179

(The NAT_Keep_Alive_Intvl value 179 was chosen to be less than the NAT session expiry time of most routers.)

(under Line_1 and Line_2 (or PSTN_Line) tabs)
NAT_Mapping_Enable: yes
NAT_Keep_Alive_Enable: yes
NAT_Keep_Alive_Msg: (this should be blank in order to send dummy packets)
NAT_Keep_Alive_Dest: $PROXY
Register Expires: 3600

----------

If you prefer not to use a STUN server then do the following:
1. Set STUN Enable: no
2. Forward the SIP ports and the RTP port range.
3. In order for the ATA/phone to know it's public IP address, make sure the ATA/phone is registered with at least one SIP registrar, or enter the public IP address into the appropriate setting in the ATA (in Linksys ATAs this setting is EXT_IP).
boatman is offline   Reply With Quote
The Following User Says Thank You to boatman For This Useful Post:
gsmlover (02-17-2009)
Unread 02-17-2009, 09:22 PM   #7
gsmlover
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 3
Thanked 0 Times in 0 Posts
gsmlover is on a distinguished road
Default

Thanks Boatman for looking into this - I just PM'ed you my voxalot contact details.

In short I tried both set of settings but unfortunately still struggling. Will really appreciate any help!
gsmlover is offline   Reply With Quote
Unread 02-18-2009, 10:42 AM   #8
awjkok
Junior Member
 
Join Date: Jan 2009
Posts: 10
Thanks: 2
Thanked 1 Time in 1 Post
awjkok is on a distinguished road
Default

Hi,

I have a linksys wrt54GP2 behind a fritz!box 7170 so basically a double NAT situation. Becaus the eu.voxalot.com server is down I had to experiment. First I tried the us.voxalot.com server because of the better ping. I got two-way sound on outbound calls. But on incoming calls I couldn't hear the caller, the caller could hear me.
I switched to au.voxalot.com and got it working two-way on incoming as well as on outgoing calls.

What might be important is that at my VSP setting I set Codecs to alaw;ulaw only; all other codecs I removed to avoid any codec problems.

The wrt54GP2 is connected via it's WAN port to an ethernet port on the Fritz!box. I updated it with the latest firmware (don't know if that matters) and used the following settings:

Subscriber Information
Display name: blank
User ID: 123456
Authentication User Name: 123456
Authentication Password: voxalot password
Registration/proxy server: voxalot.com

Nat Traversal Settings
NAT Traversal: Use NAT aware Outbound Proxy
NAT Aware Proxy Address: au.voxalot.com

Voice Quality: Best (G.711a......

Everything else I left default, no stun or port forwarding.
awjkok is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
Call Connection Rules: Where's the Incoming Digits? Jerree Voxalot Support 6 01-26-2009 10:51 PM
Incoming call form PSTN to SIP can't hear the caller sound. smart28 Voxalot Support 4 09-06-2007 03:23 AM
Incoming call problem pironato Voxalot Support 18 06-21-2007 11:25 AM
mynetfone incoming call problem with voxalot acct sida168 Voxalot Support 0 05-19-2007 01:06 AM


All times are GMT. The time now is 09:11 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.