Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 08-01-2009, 08:52 PM   #1
Cyberian75
Member
 
Join Date: Sep 2006
Posts: 36
Thanks: 7
Thanked 0 Times in 0 Posts
Cyberian75 is on a distinguished road
Default One-Way Audio

Calls through Voxalot often are only one-way audio. Direct calls to my VSPs are okay.

Symmetric NAT is off, and I'm using proxy failovers on an SPA-3000.

Any thoughts?
Cyberian75 is offline   Reply With Quote
Unread 08-02-2009, 12:22 AM   #2
carlosalbffgomes
Senior Member
 
Join Date: May 2008
Location: Portugal and Brazil
Posts: 107
Thanks: 7
Thanked 26 Times in 21 Posts
carlosalbffgomes is on a distinguished road
Default One-way-audio

Usually, one-way-audio is due to NAT problems. The reason is that your VSP doesn't know your public IP address so it can not establish a correct path to the RTP packets in both directions. There are several reasons for this kind of problem, but you can try do the following to solve it:
1 - Configure properly a STUN Server in your device;
2 - Configure port forward in your router (5060 to SIP and something else to RTP packets). In this case you don't need a STUN server, but you can also use it;
3 - Use Symmetric NAT in Voxalot account. This option introduces some delay in the voice packets but usually not noticeable. I should say that I'm using Symmetric NAT in a transatlantic scenario and the delay introduced by such configuration is almost unnoticeable.
Regards,
carlosalbffgomes is offline   Reply With Quote
Unread 08-02-2009, 12:34 AM   #3
Cyberian75
Member
 
Join Date: Sep 2006
Posts: 36
Thanks: 7
Thanked 0 Times in 0 Posts
Cyberian75 is on a distinguished road
Default

Direct calls to my VSPs are okay, though.
Cyberian75 is offline   Reply With Quote
Unread 08-02-2009, 04:32 PM   #4
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Quote:
Originally Posted by Cyberian75 View Post
Direct calls to my VSPs are okay, though.
That doesn't mean your NAT settings are correct.

If your SPA-3000 is behind a NAT router the problem may be solved by settings the following:

(under SIP tab)
Handle_VIA_received: yes
Handle_VIA_rport: yes
Insert_VIA_received: yes
Insert_VIA_rport: yes
Substitute_VIA_Addr: yes
Send_Resp_To_Src_Port: yes
STUN_Enable: yes
STUN_Server: stun.voxalot.com:3478 (or any STUN server such as 'stun01.sipphone.com:3478' or 'stun.sipgate.net:10000')
NAT_Keep_Alive_Intvl: 179

(under Line_1 and Line_2 (or PSTN_Line) tabs)
NAT_Mapping_Enable: yes
NAT_Keep_Alive_Enable: yes
NAT_Keep_Alive_Msg: (this setting should be blank)
NAT_Keep_Alive_Dest: $PROXY
Register Expires: 3600


----------

If you prefer to operate your ATA without a stun server make the following changes to the above settings:

1. Forward the SIP ports and the RTP port range from the router to the ATA.
2. Set "STUN Enable:" no
3. Set "NAT Keep Alive Enable:" no
4. In order for the ATA to know it's public IP address, make sure it is registered with at least one SIP registrar, or enter your public IP address into the "EXT IP:" field).

----------

If the problem persists it may indicate your ATA is behind a Symmetric NAT device. Here is a strategy that will adapt to whatever Symmetric NAT status is present:

1. Use settings shown above in bold type.
2. In your ATA set "STUN Test Enable:" = yes.
3. In your Voxalot account set "Symmetric NAT Handling" = yes

When active, Voxalot's "Symmetric NAT Handling" option routes the voice packets through a Voxalot proxy. Note; even when you set "Symmetric NAT Handling" = yes Voxalot will not activate this option unless it detects that your ATA has disabled NAT mapping. See the below quote from the Linksys ATA manual:

"If the STUN Enable feature is enabled and a valid STUN server is available, the Linksys ATA can perform a NAT-type discovery operation when it powers on. It contacts the configured STUN server, and the result of the discovery is reported in a Warning header in all subsequent REGISTER requests. If the Linksys ATA detects symmetric NAT or a symmetric firewall, NAT mapping is disabled."
boatman is offline   Reply With Quote
Unread 08-07-2009, 11:35 AM   #5
doctorh
Member
 
doctorh's Avatar
 
Join Date: Jul 2006
Location: Winnipeg, Manitoba, Canada
Posts: 40
Thanks: 11
Thanked 5 Times in 4 Posts
doctorh is on a distinguished road
Default

Quote:
Originally Posted by Cyberian75 View Post
Calls through Voxalot often are only one-way audio. Direct calls to my VSPs are okay.

Symmetric NAT is off, and I'm using proxy failovers on an SPA-3000.

Any thoughts?
This is not a problem in your config, but a problem in Voxalot's US servers.
Martin has fixed it in the past, by restarting some services in those servers.

It started again a couple of days ago.
doctorh is offline   Reply With Quote
The Following User Says Thank You to doctorh For This Useful Post:
Cyberian75 (08-09-2009)
Unread 08-10-2009, 05:15 PM   #6
doctorh
Member
 
doctorh's Avatar
 
Join Date: Jul 2006
Location: Winnipeg, Manitoba, Canada
Posts: 40
Thanks: 11
Thanked 5 Times in 4 Posts
doctorh is on a distinguished road
Default

Quote:
Originally Posted by doctorh View Post
This is not a problem in your config, but a problem in Voxalot's US servers.
Martin has fixed it in the past, by restarting some services in those servers.

It started again a couple of days ago.
pleeeeeeeeeeeeeeease!
doctorh is offline   Reply With Quote
Unread 08-10-2009, 06:55 PM   #7
boatman
Senior Member
 
boatman's Avatar
 
Join Date: Jul 2007
Location: Oregon, USA
Posts: 365
Thanks: 17
Thanked 77 Times in 64 Posts
boatman is on a distinguished road
Default

Quote:
Originally Posted by Cyberian75 View Post
Calls through Voxalot often are only one-way audio. Direct calls to my VSPs are okay. Symmetric NAT is off, and I'm using proxy failovers on an SPA-3000. Any thoughts?
Cyberian75,

Are you still experiencing one way audio when using one of the US servers? If so try the following steps.

Turn on "Symmetric NAT Handling" in your Voxalot account.

In your SPA-3000
1. set NAT Mapping Enable: no - (this is signals Voxalot to engage it's "Symmetric NAT Handling" function, otherwise Voxalot will not use "Symmetric NAT Handling" even if you have enabled it)
2. set Use DNS SRV: no
3. set Proxy: proxy01.us1.voxalot.com
4. set Outbound Proxy: proxy01.us1.voxalot.com
5. change "SIP Port:" to a different port (otherwise your ATA may accept an incoming call from the previous proxy until registration has expired, that could be up to 1 hour)
6. set Use Outbound Proxy: yes
7. set Use OB Proxy In Dialog: yes

In your router you may have to disable ALG as this function may re-enable NAT Mapping within the SIP packets, thereby disabling Voxalot's "Symmetric NAT Handling".
boatman is offline   Reply With Quote
Unread 08-10-2009, 07:51 PM   #8
Cyberian75
Member
 
Join Date: Sep 2006
Posts: 36
Thanks: 7
Thanked 0 Times in 0 Posts
Cyberian75 is on a distinguished road
Default

Thanks, but I gave up on using Voxalot.
Cyberian75 is offline   Reply With Quote
Unread 08-11-2009, 08:44 AM   #9
martin
 
Join Date: Feb 2006
Posts: 2,930
Thanks: 528
Thanked 646 Times in 340 Posts
martin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the roughmartin is a jewel in the rough
Default

Quote:
Originally Posted by doctorh View Post
pleeeeeeeeeeeeeeease!
Re-started RTPProxy services on both US servers. Please let me know is this has addressed your problem.
__________________
Martin

Please post support questions on the forum. Do not send PMs unless requested.
martin is offline   Reply With Quote
The Following 2 Users Say Thank You to martin For This Useful Post:
doctorh (08-12-2009), hddlab (08-11-2009)
Unread 08-11-2009, 11:09 AM   #10
hddlab
Member
 
Join Date: Jun 2007
Posts: 50
Thanks: 44
Thanked 1 Time in 1 Post
hddlab is on a distinguished road
Default

Martin, thank you very much.
I will do a lot of tests today and then I will post here the results.
regards
Jose Pinto
hddlab is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
JustVoIP and "Optimize Audio Path" option 910198 Voxalot Support 10 07-21-2009 05:42 PM
Audio problems calling *500 doctorh Voxalot Support 5 02-26-2009 01:12 PM
Optimize Audio Path - What does it do wellread1 Voxalot Support 3 12-12-2008 04:21 AM
Voxalot 800 calls audio distorted psehorne Voxalot Support 1 11-15-2007 02:40 AM


All times are GMT. The time now is 05:18 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.