Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 09-11-2008, 05:45 PM   #1
gsar
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 2
Thanked 1 Time in 1 Post
gsar is on a distinguished road
Exclamation dial plan oddity

I'm trying to setup a dial plan that allows me to select a particular provider by dialing a prefix, like so:

Code:
Pattern     Replacement    Provider
_#1.        ${EXTEN:2}     Provider1
_#2.        ${EXTEN:2}     Provider2
_#3.        ${EXTEN:2}     Provider3
Pretty standard stuff, right? Except it doesn't work!

When I dial #3NNNN on the phone, the SIP logs of my SPA-2102 show that it is sending it to %233NNNN@us.voxalot.com (note the "#" has been escaped as %23) and Voxalot comes back with "the number you've called cannot be connected, please try again". I also tried ${EXTEN:4} to cope with the escaping, but that didn't change the outcome.

If I change the above dial plan to:

Code:
Pattern     Replacement    Provider
_1*.        ${EXTEN:2}     Provider1
_2*.        ${EXTEN:2}     Provider2
_3*.        ${EXTEN:2}     Provider3
and dial 3*NNNN instead, then I can see in the logs that the request goes out to the unescaped address 3*NNNN@us.voxalot.com and the call actually completes with Provider3 as expected.

Now the question: Is this a bug? Or have I misunderstood how Voxalot dialplans are supposed to work?

Any clues appreciated.

P.S: My SPA dialplan is very simple:
Code:
([x#*][x*].)
gsar is offline   Reply With Quote
Unread 09-11-2008, 06:12 PM   #2
wmp
Member
 
Join Date: Mar 2006
Posts: 65
Thanks: 11
Thanked 11 Times in 9 Posts
wmp is on a distinguished road
Default

I am using this without a problem:

_#1XX. ${EXTEN:2} Provider 1
_#2XX. ${EXTEN:2} Provider 2
wmp is offline   Reply With Quote
Unread 09-11-2008, 06:50 PM   #3
gsar
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 2
Thanked 1 Time in 1 Post
gsar is on a distinguished road
Default

Quote:
Originally Posted by wmp View Post
I am using this without a problem:

_#1XX. ${EXTEN:2} Provider 1
_#2XX. ${EXTEN:2} Provider 2
Interesting, what kind of ATA do you have? If possible, could you kindly confirm if it does the same escaping as mine does?

I can confirm that using "_#1XX." instead of "_#1." doesn't make it work for me. I've tried it with a few different providers, so it doesn't seem provider specific.
gsar is offline   Reply With Quote
Unread 09-11-2008, 09:10 PM   #4
wmp
Member
 
Join Date: Mar 2006
Posts: 65
Thanks: 11
Thanked 11 Times in 9 Posts
wmp is on a distinguished road
Default

I'm using a Sipura SPA-2000. Here is the dial plan I am using:
Code:
(911S0|#x<:1850>[2-9]xxxxxx|#x<:1>[2-9]xx[2-9]xxxxxxS0|#x1[2-9]xx[2-9]xxxxxxS0|<:1850>[2-9]xxxxxx|<:1>[2-9]xx[2-9]xxxxxxS0|1[2-9]xx[2-9]xxxxxxS0|[x*][x*].)
Not sure how to test what is being sent to Voxalot.
wmp is offline   Reply With Quote
The Following User Says Thank You to wmp For This Useful Post:
gsar (09-12-2008)
Unread 09-12-2008, 02:26 AM   #5
gsar
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 2
Thanked 1 Time in 1 Post
gsar is on a distinguished road
Default

I found a reference to the same problem in another thread here, so it seems like a Voxalot dial plan implementation issue. That thread seems to have ended with an explanation that is incorrect--the SPA is able to pass the "#" character through iff it is part of the SPA dialplan, even if the "#" is at the end of the dialed sequence. For example, if your SPA dialplan is ([x#*][x#*].) dialing #123# will send all five characters through and the "send" function associated with # is disabled.
gsar is offline   Reply With Quote
Unread 09-12-2008, 05:05 AM   #6
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

Quote:
Originally Posted by gsar View Post
I found a reference to the same problem in another thread here, so it seems like a Voxalot dial plan implementation issue. That thread seems to have ended with an explanation that is incorrect--the SPA is able to pass the "#" character through iff it is part of the SPA dialplan, even if the "#" is at the end of the dialed sequence. For example, if your SPA dialplan is ([x#*][x#*].) dialing #123# will send all five characters through and the "send" function associated with # is disabled.
Chances are the issue at hand is somehting along these lines http://forum.voxalot.com/voxalot-sup....html#post5902

So this is a hardware specific issue or rather an issue possibly confined to Certain ATAs and VoXalot...

The fact that most other Linksys devices can work fine with VoXalot...makes me think that chances are that an upgrade to the firmware of SPA2100 you have may take care of this...

But....is it worth the time and headache to go upgrading firmware when you could just as easily use _1*x. for example...?
emoci is offline   Reply With Quote
The Following User Says Thank You to emoci For This Useful Post:
gsar (09-12-2008)
Unread 09-12-2008, 09:43 AM   #7
gsar
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 2
Thanked 1 Time in 1 Post
gsar is on a distinguished road
Default

Thanks for finding that thread, yes it is exactly the same issue.

The only reason I would like to use the #N sequence is because my folks at home have already been trained to use it from my previous SPA dialplan and I don't want to have to retrain them. It took a while to train them the first time around.

Assuming this can't be easily fixed on the Voxalot side or by a firmware update, it should be possible for me to just do a SPA dialplan-level translation like this and change the Voxalot dialplan to use N* instead of #N:

Code:
Old dialplan: ([x#*][x*].)

New dialplan: (<#1,:1*>[x*][x*].|<#2,:2*>[x*][x*].|<#3,:3*>[x*][x*].)
I hope that would do the trick.

Thanks again for the feedback!
gsar is offline   Reply With Quote
Unread 09-12-2008, 10:05 AM   #8
gsar
Junior Member
 
Join Date: Sep 2008
Posts: 8
Thanks: 2
Thanked 1 Time in 1 Post
gsar is on a distinguished road
Default

I'm now using this (slightly more elegant) SPA dialplan to workaround the issue:

Code:
(<#:>x,<:*>[x*].|[x*][x*].)
Works like a charm.
gsar is offline   Reply With Quote
The Following User Says Thank You to gsar For This Useful Post:
martin (09-12-2008)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dial plan and various problems 800793 Voxalot Support 6 11-19-2007 01:05 PM
Question on speed Dial plan between Voxalot member. klap282799 Voxalot Support 2 09-17-2007 09:58 PM
Dial plan problems with FaktorTel and VoXaLoT Hally Voxalot Support 1 01-06-2007 09:21 AM
Norway toll free number dial plan ? shezad Voxalot Support 1 11-11-2006 12:09 AM
dial plan help please muzzza Voxalot Support 0 09-01-2006 11:38 AM


All times are GMT. The time now is 04:17 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.