Click Here To Visit SIP Broker  

Go Back   Voxalot / SIP Broker Support Forums > Voxalot Forums > Voxalot Support

Voxalot Support Support for the Voxalot service.

 
 
Reply
Thread Tools Display Modes
Unread 11-14-2010, 11:51 AM   #1
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default Linksys PAP2 audio issues only for incoming calls

Hi,
I have been trying to figure out a solution to this problem for the past 10 hours but have so far been unsuccessful. Here is the problem.

I have configured my PAP2 adapter according to the voxalot PAP2 guide. I am able to make outgoing calls and everything works fine. But when someone calls my voxalot account via SIP Broker, I am unable to hear their voice though they can hear mine. Also if someone calls me directly using the SIP URI xxxx@eu.voxalot.com, audio is not heard both ways.

From what I've read on the forums, this mostly seems to be some NAT issue. But the strange part is that when I connect to the voxalot account either using X-lite (in Windows) or iSIP (in iPod Touch), there are no audio issues with incoming calls. Both the smartphone and the desktop PC are in the same LAN as the PAP2. Something advanced like MAC / IP based blocking cannot be the cause as my LAN is behind a simple ADSL router.

I have tried all possible configurations and yet am unsuccessful. Here are my current PAP2 settings:

SIP:
Handle VIA received: no
Handle VIA rport: no
Insert VIA received: no
Insert VIA rport: no
Substitute VIA Addr: yes
Send Resp To Src Port: yes
STUN Enable: yes
STUN Test Enable: no
STUN Server: stun.voxalot.com
NAT Keep Alive Intvl: 15

Line 1:
NAT Mapping Enable: yes
NAT Keep Alive Enable: yes
Make Call Without Reg: yes
Ans Call Without Reg: yes
Enable IP Dialing: yes

The remaining PAP2 settings are those whose are described in the voxalot PAP2 guide.

The interesting part is that previously I had set to port forward 5060 from the adsl router to my PAP2 device and then if someone called using the SIP URI xxxx@<public IP of router>, it worked without any sound issues.

I am thinking that there is some small configuration change I should do in PAP2 to resolve this issue. Any help would be really appreciated. Thanks.
amaramrahul is offline   Reply With Quote
Unread 11-14-2010, 11:56 AM   #2
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default

Some additional info. As I told, outgoing calls to other SIP URIs and landline phones (using a VoIP service provider I have configured in Voxalot) work fine. Test call to *600 also works fine. It is only the incoming calls which has sound issues .
amaramrahul is offline   Reply With Quote
Unread 11-14-2010, 04:32 PM   #3
Ron
 
Join Date: Feb 2006
Posts: 447
Thanks: 4
Thanked 8 Times in 8 Posts
Ron will become famous soon enough
Default

Handle VIA received: yes
Handle VIA rport: yes
Insert VIA received: yes
Insert VIA rport: yes
Substitute VIA Addr: yes
Send Resp To Src Port: yes
STUN Enable: yes
STUN Test Enable: yes
STUN Server: stun.voxalot.com:3478


In your router, forward the PAP2's SIP ports (typically 5060-5061) and the PAP2's RTP ports (typically 16384-16482) to the PAP2's LAN IP address.
Ron is offline   Reply With Quote
The Following User Says Thank You to Ron For This Useful Post:
amaramrahul (11-14-2010)
Unread 11-14-2010, 06:43 PM   #4
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default

Another small update. I upgraded firmware from 3.1.15 to 5.1.6 and the issue seems to still be there. Also I cannot port forward those ports. Moreover i dont think that should be necessary as x-lite had no issues. So if I am not port forwarding, should I still change the values to yes?
amaramrahul is offline   Reply With Quote
Unread 11-15-2010, 08:18 AM   #5
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default

Thanks for the response. As suggested I tried setting all to yes. Yet it did not work. Perhaps the port forwarding is mandatory but that is not an option for me. The question "why only PAP2 is giving me this problem while X-lite works?" still puzzles me.
amaramrahul is offline   Reply With Quote
Unread 11-15-2010, 08:56 AM   #6
snvv
Junior Member
 
Join Date: Oct 2008
Posts: 26
Thanks: 3
Thanked 1 Time in 1 Post
snvv is on a distinguished road
Default

You may try
STUN: 72.51.45.215:3478
or
stun.xten.com
or

stun.sipgate.net:10000

If that does not work try
Proxy: eu.voxalot.com
Outbound Proxy: eu.voxalot.com
Use Outbound Proxy: yes
Use OB Proxy In Dialog: yes

Regards
snvv
snvv is offline   Reply With Quote
Unread 11-15-2010, 06:45 PM   #7
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default

Thanks for the prompt response. I've tried changing the STUN server as well as setting outbound proxy (I even tried the proxy settings as described in the guide). Yet wasn't successful .

Is there anyone who has tested voxalot incoming on a PAP2T? I just want to confirm that this is some issue with PAP2T+Voxalot. I have configured many PAP2T phones (though none with Voxalot) so far and this is the first time I am facing audio issues even after setting STUN and NAT mapping.

Any more suggestions?
amaramrahul is offline   Reply With Quote
Unread 11-17-2010, 03:15 AM   #8
emoci
 
Join Date: Jul 2007
Location: Toronto, Canada
Posts: 1,422
Thanks: 123
Thanked 369 Times in 282 Posts
emoci is a name known to allemoci is a name known to allemoci is a name known to allemoci is a name known to all
Default

How are you testing incoming calls to VoXalot?

I would suggest:

-Call local SipBroker number. When prompted enter *010-123456 (where 123456 is your VoXalot number). Does the call ring...is there audio etc.

-Or try entering your SIP URI 123456@voxalot.com here: SIPBroker - EziDial ... do you receive and incoming casll from the Echo test server?
emoci is offline   Reply With Quote
Unread 11-17-2010, 05:29 AM   #9
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default

There are multiple ways I have tried incoming calls. Assuming xxxxxx is my voxalot id.

1. Calling directly from another SIP adapter (in a different network) to xxxxxx@eu.voxalot.com. [Phone rings but no audio both ways]

2. Calling from another registed voxalot account to xxxxxx@eu.voxalot.com [Phone rings but no audio both ways]

3. Calling the SIP broker service and dialling *010xxxxxx [Phone rings and from what I remember only the caller is able to hear the voice]

4. Calling the SIP broker service and dialling *013<enum number pointing to xxxxxx@eu.voxalot.com> [Phone rings but only the caller is able to hear the voice]

I am now thinking of configuring Callcentric on another line and testing incoming. Because if that works, then at least I could rule out issues with firmware and/or network.

Btw, thanks for all the responses. It gives me one more reason why I should not give up on Voxalot .

Last edited by amaramrahul; 11-17-2010 at 05:31 AM.
amaramrahul is offline   Reply With Quote
Unread 11-17-2010, 07:33 AM   #10
amaramrahul
Junior Member
 
Join Date: Nov 2010
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
amaramrahul is on a distinguished road
Default

Alright this gets more puzzling. I've just configured my callcentric account on Line 2 by following the guide at Linksys PAP2 configuration. And guess what! Incoming works perfectly for call centric. I've tried calling through SIP Broker as well as direct SIP uri (xxxxxxxxxxxx@in.callcentric.com) and both of them work perfectly. No port triggering! No port forwarding!

So, the issue I am facing, is this specific to Voxalot+PAP2? Should this be raised as a bug somewhere? Could someone kindly confirm?
amaramrahul is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Free DID Numbers, Free Voip Calls, & more Voip Info amroe Voxalot General 54 01-13-2014 09:11 AM
Incoming Calls Drop or No Audio All4Fun Voxalot Support 24 07-31-2009 10:55 PM
Voxalot 800 calls audio distorted psehorne Voxalot Support 1 11-15-2007 02:40 AM
Voxalot --> Voxalot calls are not getting completed? Any issues shibukraj Voxalot Support 2 01-09-2007 04:16 AM


All times are GMT. The time now is 08:19 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.