Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (http://forum.sipbroker.com/index.php)
-   Voxalot Support (http://forum.sipbroker.com/forumdisplay.php?f=4)
-   -   *500 to voicemail does not work (http://forum.sipbroker.com/showthread.php?t=2968)

psehorne 04-03-2008 11:15 PM

*500 to voicemail does not work
 
When I dial *500 from my ATA I get a recording "We're sorry. The number you have dialed cannot be connected." If I dial a SIPBROKER access number and then dial *010 500, I get into voicemail.

What to do?

Thanks,
Paul

emoci 04-04-2008 12:22 AM

Quote:

Originally Posted by psehorne (Post 16110)
When I dial *500 from my ATA I get a recording "We're sorry. The number you have dialed cannot be connected." If I dial a SIPBROKER access number and then dial *010 500, I get into voicemail.

What to do?

Thanks,
Paul


This is likely a Dial Plan issue, either with the Dial Plan in your ATA....or one of the Dial Rules in VoXalot maybe interfering...

1. Under Smart Call/Dial Plan when logged into VoXalot there is a test field, type *500 and see what it says regarding how it'll route this call (if you happen to have any dial plans that utilize *, that could be the issue.....

If everything looks fine there

2. Save your current ATA dialplan on a text file so you can restore it if need be, and set your dial plan in the ATA to just [*x][*x]. (this is Linksys specific, so depending on your ATA it may need to be tweaked)

Hopefully one of those two will change things, or point you to the problem

The fact that you are getting that message, means the call is hitting VoXalot though, which means it is likely the first case....

Question: Was this working before, or is it the first time you try it?

psehorne 04-04-2008 03:11 AM

Quote:

Originally Posted by emoci (Post 16112)
1. Under Smart Call/Dial Plan when logged into VoXalot there is a test field, type *500 and see what it says regarding how it'll route this call

Result of this test = "A call to:*500 will get forwarded to 500 via Voxalot"


Quote:

Originally Posted by emoci (Post 16112)
(if you happen to have any dial plans that utilize *, that could be the issue.....

The only Dial Plan that I have that begins with an asterisk is _*18. (including the period). I don't think this should interfere with *500, but I've deactivated it anyway and still have the problem. However, I do have a fall through Dial Plan number 999 (if no other Dial Plan applies) which is _xxxx. (including the period). Could this be the problem? Does the result of the test above (500 with no asterisk) cause this to fall through to _xxxx. ?


Quote:

Originally Posted by emoci (Post 16112)
2. Save your current ATA dialplan on a text file so you can restore it if need be, and set your dial plan in the ATA to just [*x][*x]. (this is Linksys specific, so depending on your ATA it may need to be tweaked)

I'm using a Grandstream HT386. There are no dial plans (I wish there were). The PSTN access code is *00, but I don't think this would cause the problem.


Quote:

Originally Posted by emoci (Post 16112)
Question: Was this working before, or is it the first time you try it?

This is first time I've tried it.

Quote:

Originally Posted by emoci (Post 16112)
This is likely a Dial Plan issue, either with the Dial Plan in your ATA....or one of the Dial Rules in VoXalot maybe interfering...

Like you, I believe the call is getting to Voxalot, but I don't know how to tell what is getting to Voxalot or how Voxalot is handling it (except for the test above).

Paul

psehorne 04-04-2008 03:18 AM

Quote:

Originally Posted by psehorne (Post 16113)
However, I do have a fall through Dial Plan number 999 (if no other Dial Plan applies) which is _xxxx. (including the period). Could this be the problem? Does the result of the test above (500 with no asterisk) cause this to fall through to _xxxx. ?

I disabled the above mentioned dial plan and still have the problem (assuming that changes take place immediately.

Paul

emoci 04-04-2008 04:04 AM

Hmm....,

What happens if you just call 500 (without *)?

kurun 04-04-2008 04:09 AM

Try dialing 500 from your ATA to get to your Voicemail.
This should work as Voxalot supports it.

This issue is probably caused by the local Call Features "*xx" codes used by Grandstream in their ATA.
The code *50 disables call waiting and only the last 0 would be passed on to Voxalot, when you dial *500.
This results in the message "We're sorry. The number you have dialed cannot be connected."

Another option is to set "Enable Call Features" to No in the set-up screen.

Keep in mind that calls starting with an "*" and followed by 2 digits that match any one of the call features as used by a Grandstream ATA, will not go through correctly as the ATA will chew out the first three characters. They will never pass on to Voxalot.

So if you want to keep the ATA Call features active, you will have to create a dial plan such that you can still call sipbroker codes where this problem occurs.

For example, to call a Pennytel extension, instead of dialing *234-123456, you could dial 9*234123456. Then set up a dial plan such that matches on _9*xx. with a replacement of ${Exten:1} sent via Provider - Sipbroker. This bypsses the ATA's call features filter and lets the dialed number get to Voxalot.

By the way *23 is the Call feature code for 3-Way conference on the Grandstream ATA.

Hope this helps ..........

psehorne 04-04-2008 04:24 AM

Quote:

Originally Posted by emoci (Post 16115)
Hmm....,

What happens if you just call 500 (without *)?

I get told "I'm sorry, your call cannot be completed as dialed"

CORRECTION: It works if I just dial 500.

Thanks,
Paul

psehorne 04-04-2008 04:39 AM

Quote:

Originally Posted by kurun (Post 16116)
Try dialing 500 from your ATA to get to your Voicemail.
This should work as Voxalot supports it.

This issue is probably caused by the local Call Features "*xx" codes used by Grandstream in their ATA.
The code *50 disables call waiting and only the last 0 would be passed on to Voxalot, when you dial *500.
This results in the message "We're sorry. The number you have dialed cannot be connected."

Another option is to set "Enable Call Features" to No in the set-up screen.

Keep in mind that calls starting with an "*" and followed by 2 digits that match any one of the call features as used by a Grandstream ATA, will not go through correctly as the ATA will chew out the first three characters. They will never pass on to Voxalot.

So if you want to keep the ATA Call features active, you will have to create a dial plan such that you can still call sipbroker codes where this problem occurs.

For example, to call a Pennytel extension, instead of dialing *234-123456, you could dial 9*234123456. Then set up a dial plan such that matches on _9*xx. with a replacement of ${Exten:1} sent via Provider - Sipbroker. This bypsses the ATA's call features filter and lets the dialed number get to Voxalot.

By the way *23 is the Call feature code for 3-Way conference on the Grandstream ATA.

Hope this helps ..........

It was months ago that I installed the Grandstream ATA (and read the manual) and I had forgotten about the Grandstream * feature codes. Thanks for reminding me.

Dialing 500 without the asterisk worked.

Thanks,
Paul

psehorne 04-04-2008 05:08 AM

Quote:

Originally Posted by kurun (Post 16116)
This issue is probably caused by the local Call Features "*xx" codes used by Grandstream in their ATA.

I disabled the Call Features in the Grandstream, and now *500 works.

Thanks,
Paul


All times are GMT. The time now is 02:53 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.