Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (http://forum.sipbroker.com/index.php)
-   Voxalot Support (http://forum.sipbroker.com/forumdisplay.php?f=4)
-   -   Mute outbound call syndrome; Betamax issue? (http://forum.sipbroker.com/showthread.php?t=5186)

tatjam 05-20-2010 05:12 PM

Mute outbound call syndrome; Betamax issue?
Hi. I made up a title for a problem I encounter fairly frequently using my VOIP setup. I call it "mute outbound call syndrome" (MOCS, for short). The problem manifests in the following way: very frequently (probably 25% of the time) when I place outbound calls, I can hear the person I'm calling perfectly, but they cannot hear anything I say. Or, if it's an automated system, I can hear the recording, but all key presses I make don't register at the automated system.

Here's my setup. I have a Sipura 2100 ATA that registers with Voxalot. My VSP is a Betamax reseller--justvoip. I should mention that both my phone and my ATA actually have two lines, and I've tried registering the second line directly with justvoip, e.g., making it such that my outgoing calls do not go through voxalot. No matter which of those two variants I use, I still get the MOCS problem. That leads me to believe the MOCS problem has to do with Betamax and their funky service.

MOCS is quite arbitrary. I can be making several calls, for example, and the first 2 or 3 tries result in MOCS: I can hear the person I'm calling but they can't hear me. Suddenly, on the next try, they can hear me. Or on a given day several tries over a period of a few hours result in MOCS. Later that same day, calls get terminated normally. I can't see any rhyme or reason to this. But again, as I said, this happens with some frequency--something like about 25% of the time I experience MOCS.

So, a coupla questions. Any others here who use Betamax as their VSP ever experience MOCS? And finally, are there any settings I might tweak on my ATA to address the issue? It's getting a bit frustrating.


EDIT: I was relying on some faint memories when I said I get MOCS as well when using line 2 (direct registration with justvoip, not using voxalot as intermediary). Now that I've resurrected line 2 for further experimentation, I'm backing off from the claim that the line that registers directly with justvoip is giving me MOCS problems. In severals days' testing, I've so far never gotten MOCS on that line. Rather, every time I call using line 1 (voxalot registration with justvoip as VSP) and get MOCS, if I immediately call back the same number using line 2 (direct registration with justvoip), the MOCS problem disappears. I'll do a further update to this post if I ever do get MOCS on line 2. But so far, in renewed testing, that has not happened.

tatjam 05-21-2010 03:02 AM

I should add that I never have anything like the MOCS problem with incoming calls. So far as I can tell, I'm always able to hear callers making incoming calls and they can hear me as well. Hence the "outbound" part of the title I've created for this problem.


kurun 05-21-2010 01:16 PM

If you call from the Justvoip windows softphone, do you still get the problem?
It does sound like an ATA / network set-up isuue.

Is your ATA operating behind a router ?
Are you using the Voxaot STUN server (stun.voxalot.com:3478) ?

tatjam 05-21-2010 06:41 PM

Thanks for your response, kurun. Unfortunately, I don't have any Windows on which I can run the justvoip softphone: I've striven to be Windows-free for a few years now, and have largely succeeded. Do you happen to know if/how that softphone functions under WINE? I could try that, if it actually runs under WINE.

And yes, my ATA is behind a router. Should've mentioned that when I described my setup. So that does add another possible point of failure. I tried at some point to fiddle with QoS settings, but did not comprehend very well what to do there. I do have the option of putting the ATA in the DMZ, which seems like it could affect things if I'm having router issues. I actually switched my STUN server to stun.justvoip.com. But I do believe that, at some point, I had it set to the voxalot STUN server.

Any recommendations based on this further description?


tatjam 05-21-2010 07:43 PM

I can't get the justvoip softphone to function properly under WINE, so I couldn't try that. I tried using the Linphone softphone, which generally works for me. But it wasn't registering properly for some reason. So I went back to experimenting with the second line on my ATA--which, as mentioned above, is configured to register directly with justvoip, not going through voxalot.

Here are some initial results. Called a number using the second line and it terminated normally: I could hear the other party fine, and they could hear me fine. I asked if I could call back immediately and they agreed. I used line 1 for this second call--the line that registers with voxalot and uses justvoip as VSP. I got MOCS on that call: I could hear the other party fine, but they could not hear me. I hung up and called them back immediately again using line 2 (the one with justvoip direct register) and MOCS was not in play: just like the first call I made to them using line 2, I could hear them just fine and they could hear me.

So, it looks in this case like the issue has something to do with the way justvoip and voxalot are interacting, does it not? I'll keep experimenting to see whether, every time I get MOCS on line 1 (voxalot with justvoip as VSP), the issue goes away when I use line 2 (direct registration with justvoip, not going through voxalot). As I recall I did, in the past, have the MOCS issue on line 2 as well. But I'll have to try this all anew to confirm that.


Corbu' 05-22-2010 01:42 AM

Maybe you want to take a look in this topic. I experience that but very rarely. Sometimes the line is total silence, simetimes the audio is just one way. On some other ocasions I can't hear the ring tones, but it goes back to normal once the calee picks up the phone. I don't use an ATA, I use Voxalot and PBXes Callthru.

kurun 05-22-2010 04:59 AM

I am told that the Betamax softphone does not run correctly under Wine, though I have never tried it myself.

I am using the Ekiga softphone under Ubuntu and it seems to work quite well with Betamax accounts. I have tested it with Voipcheap, Intervoip, Actionvoip and Poivy.

I use the Voxalot Stun server to connect behind the firewall.

Are you using different SIP and RTP ports for the 2 accounts on your ATA?

I am also using a couple of Betamax accounts with my Voxalot account registered on a Grandstream ATA, and generally the calls to PSTN numbers go through with no problem.

tatjam 05-22-2010 04:01 PM

Since yesterday I've been getting MOCS on line 1 (voxalot registration with justvoip as VSP) every time I call a PSTN number. If I immediately call back that same number using line 2 (direct registration with justvoip), the MOCS problem goes away. I don't think I've ever had MOCS persist for so lengthy an interval.

And yes, I do have different SIP ports configured for these two accounts--5060 and 5061. I do not see any option in the ATA's web interface to set differing RTP ports, though. I have switched back to the voxalot STUN server, by the way, which has not resolved the MOCS problem.

As I'm now thinking of some analysis I was formulating earlier with regard to this problem, I was previously leaning toward the conclusion that this problem relates to voxalot rather than to my betamax provider. As I'm now recalling, one key factor leading me to lean toward that conclusion was the fact that I sometimes get MOCS when I'm calling another voxalot user: in those cases, there can be no question of poor interaction between voxalot and a VSP, since it all goes through voxalot. We haven't placed such a call for a few weeks since my father-in-law is now visiting us. But during much of the year we call him very regularly, and I've definitely seen the MOCS problem in the past when calling him, and he's seen it when calling me, too (I set up and ATA configured to register his voxalot account on his internet connection).

Thus, the mystery deepens . . .


kurun 05-22-2010 11:22 PM

Try setting the second account to Port 5062.
Not sure if this makes a difference with Voxalot.

Also, have you tried using your ATA with a public IP address just to identify if it is an NAT issue?

Unfortunately, I am not familiar with the Sipura 2100 ATA setups.

tatjam 05-23-2010 01:36 AM

I haven't tried giving the ATA a public address yet because I'm afraid it might interfere with my dyndns connection to my router. But it's certainly true doing that could be revelatory.

For now, though, I want to continue experimentation with line 2 (the one with direct registration with justvoip). I was recalling--as I posted above--that I sometimes get MOCS on that line, too, but I'm now uncertain about that. I'll keep trying that line each time MOCS occurs on line 1 (voxalot registration with justvoip set as VSP on that line) to see if I can ever get MOCS to occur on line 2. So far it hasn't, but it's only been about a day since I reconstituted that line. Seeing whether my recollection that MOCS sometimes occurs on that line is correct or not could also be revelatory of where the problem lies.

Further updates to come as I continue these tests.


All times are GMT. The time now is 02:03 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.