Voxalot / SIP Broker Support Forums

Voxalot / SIP Broker Support Forums (http://forum.sipbroker.com/index.php)
-   Voxalot Support (http://forum.sipbroker.com/forumdisplay.php?f=4)
-   -   Incoming calls ring, but cannot hear voice (http://forum.sipbroker.com/showthread.php?t=4251)

sahildoshi 08-20-2009 01:16 PM

Incoming calls ring, but cannot hear voice
 
This is my setup:

I have a Cable Modem, connected to a D-Link DIR-615, which then connects to my Grandstream Handytone 486 ATA.

Before I got the D-Link DIR-615, I was using a Linksys WRT54G with a DD-WRT firmware. With that setup, I had absolutely no problems with my VOIP.

After shifting to the D-Link however, I have started to notice that I often get calls, in which I cannot hear the other party. The other party claims that they cannot hear me either. Sometimes, they claim that the phone keeps on ringing, as if nobody has answered, and sometimes they claim that they don't hear anything, and yet on my side, the phone rings, and after I pick up, I cannot hear anything.

I have tried testing this by using my Mobile phone's SIP settings to make an "internet call" to my Voip adapter (using an E71). If I call from within the network, the phone rings, but I cannot hear on both sides. If I call from outside the network, I get through fine, and I can hear both in sides in my Mobile phone and in my ATA.

I tried playing around with some settings (like changed around codecs, added a stun server, etc), but I have the same results. I asked the other party to call me using *010 (as they are calling me from another voxalot #), and when they do that, the chances of getting through increase, but there are still many instances where the call doesn't go through.

I though that it might be the connection of the other party, but they claim that when they call other Voxalot users, they don't have any problems. (Suggesting that there is a problem with my setup).

Does anybody have an idea of what I should do? Is it the D-Link settings that need some work? (I haven't really messed around with those too much).

I hope to get a response soon.

Thank you!

boatman 08-20-2009 06:33 PM

If your router has SPI or ALG features you may have to disable one or both of those features.

If your Grandstream Handytone 486 ATA can make a direct IP call try calling this test number: *0@proxy01.sipphone.com:5060
If the message says you are behind a SIP compatible router that means your ATA is sending your public IP address as the RTP contact address, as it should. If you hear "you may experience call completion problems behind this router" that means your ATA is not sending it's public IP address as the RTP contact address, and probably sending it's local IP address instead.

If the problem persists even when using a STUN server then try forwarding the SIP port and full range of RTP ports used by your ATA. When you forward ports you probably won't need to use a STUN server.


All times are GMT. The time now is 05:15 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.